Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The server was upgraded from 10.5 from 10.6, during the upgrade the Reverse Zones were lost so I tried to recreate these but found that it's best to delete all zones, definitions and start again.

So I've started again and Reverse Zones are appearing but I'm still having issues. I receive the following errors (if they help)

01-Nov-2010 12:52:01.254 client 192.168.1.52#57051: view com.apple.ServerAdmin.DNS.public: query (cache) 'server.dev.home.gateway/A/IN' denied
01-Nov-2010 12:59:24.487 client 192.168.1.52#52858: view com.apple.ServerAdmin.DNS.public: query (cache) 'earth.server.dev.home.gateway/A/IN' denied

At the moment I have the following setup in the DNS

1.168.192.in-addr.arpa. Reverse Zone
   192.168.1.100        Reverse Mapping     MacPro-Server.local.
server.dev.             Primary Zone
   server.dev.          Machine             192.168.1.100
   earth.server.dev.    Alias               server.dev.
share|improve this question
3  
I understand from the errors that you are issuing a DNS request from client 192.168.1.52. The server denied the request. Check your configuration for something like allow-query, allow-recursion (These options are from bind). –  Khaled Nov 1 '10 at 9:02
    
Thanks mate, that fixed the problem ! –  dallasclark Nov 1 '10 at 22:27
add comment

1 Answer 1

DNS is not my strong point, but it looks like your reverse mapping isn't configured correctly. It should be pointing to server.dev., not MacPro-Server.local.

Try sudo changeip -checkhostname, and you should get an answer like "The names match, nothing to change". If you don't, you'll need to fix that, which is also done via changeip. man changeip for more examples.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.