Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Apache, and then I tried writing http://localhost/ in the browser. It's not working and saying page not found. But, works.

What problem do I have, and how can I resolve it?

share|improve this question

migrated from Nov 1 '10 at 5:47

This question came from our site for professional and enthusiast programmers.

Have you tried with at least 2 browsers? – irrelephant Nov 1 '10 at 4:28
nup and got my answer from john – Subhransu Mishra Nov 1 '10 at 5:06
Glad I could help. :) – John Nov 1 '10 at 5:21
up vote 6 down vote accepted

It could be that your hosts file does not map localhost to the loopback IP ( On Windows, your hosts file should be at \Windows\system32\drivers\etc\hosts. On *NIX, it should be at /etc/hosts. Check those files and verify that localhost is mapped to the loopback IP. If not, add it.

Here are some resources that might help you. Take a look.

share|improve this answer
Thanks Wuputah. :) – John Nov 1 '10 at 5:21
Note, newer versions of Windows do the localhost mapping (for both IPv4 and IPv6) in the DNS client, so the entry in hosts is correctly commented out. – Richard Nov 1 '10 at 8:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.