Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having some troubles with Virtualmin and Webmin. Until recently if I added a virtual server or any kind of server, Virtualmin would configure all my DNS settings and Apache settings automatically. I wouldn't have to do much to get a new domain online which was quite handy.

Now, when I create a new virtual server it doesn't do this for me. If I look at a server that was created before, then in the left hand column of the menu there are options such as 'DNS Domain' and 'Configure website' but the new ones don't have that. I have checked out the Server Templates and they seem fine and I definitely haven't changed them.

Does anyone know what could be causing this behaviour?

share|improve this question
    
Is the "DNS" option checked on in the virtual server's config page? I think it's "Create DNS record" or so under "Configurable Options". –  Rob Olmos Nov 3 '10 at 5:54
add comment

1 Answer

up vote 0 down vote accepted

Turns out it was a problem with the Modules that were enabled in Virtualmin. I went to System Settings > Features and Plugins and several of the options had been disabled by default. This was due to several factors such as my DNS server being restarted and me fiddling around with other modules.

Once I fixed all the dependencies and was able to enable all the 'features and plugins' that I needed, It started working as desired.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.