Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just set up the internet at my new apartment and I can no longer SSH into my office development server or reach some links on the network.

It is behind a VPN and the Cisco VPN client says its connecting fine, but I still cant seem to reach the link or SSH in.

I dont think the server/VPN is blocking me because I have always been able to login from random Starbucks and other WiFi connections. But now I can't from my home internet.

I am plugged directly into the Verizon modem so there is no router in the way. If run a traceroute to the server IP address it gets hungup way out in the Internet ether.

How can I further debug this. BTW we have no IT guy who manages our servers so I can't talk to him/her and also Verizon is absolutely clueless. I already spent hours on the phone with them.

UPDATE Things that work

I can ping the Firewall fine (both on and off VPN)

I can ping the default gateway fine (both on and off VPN)

Traceroute (both on/off VPN) to both IPs always dies at the same place host-216-57-131-230.customer.veroxity.net (216.57.131.230) which is one of the providers to the colo place and also looks like it is undergoing a merger right now http://veroxity.com/

share|improve this question
    
Ha that's funny you called Verizon, might as well have called the starbucks you sometimes connect from. +1 for making me laugh. But anyways can you ping any computer on your work network (i.e. besides the vpn server?). When you have vpn on can you ping sites external to your office private range? –  Marm0t Nov 2 '10 at 18:43

3 Answers 3

Just out of curiosity can you plug your machine into an Ethernet wired connection and try to VPN without using the wireless WIFI connection and see if that works. this of course is not a solution but some troubleshooting to isolate the problem.

if it is plugged in try disabling the wifi adapter on the machine during this test.

share|improve this answer
    
WIFI is disable on the modem and I actually cant plug directly into the Ethernet wired connection as the modem is plugged into a phone line. thanks –  JiminyCricket Nov 2 '10 at 15:10

Just some thoughts.

Can you ping the VPN server? Can you do a traceroute to the VPN server? Do this without connecting the Cisco VPN and then with it connected. If you can do it without the client connected, it sounds like routing is wrong on your machine once the VPN gets connected.

Can you force your cable modem to grab a different IP address, if it is DHCP? From your office, can you ping your cable modem? When you say you can't reach other places on the network, are you talking about your work Intranet or other places on the Internet?

share|improve this answer
    
please see updates above about Ping/Traceroute. I can't reach other places on the intranet, access our SVN trunk our SSH into any server behind the firewall. –  JiminyCricket Nov 2 '10 at 16:15
    
Try removing or moving your .known_hosts file. Try connecting with ssh -v from the command line. –  dmah Nov 2 '10 at 16:50
    
I removed known-hosts and also did an ssh -v. It prints the correct internal IP for the dev server so I know that its looking in the right place. It says that the host is down though, which I can verify is not true. –  JiminyCricket Nov 2 '10 at 21:24
    
Is sshd listening on a non-standard port? Is your ssh client trying to connect on a non-standard port? –  dmah Nov 2 '10 at 21:26
    
port 22. thats standard right? –  JiminyCricket Nov 2 '10 at 21:30
up vote 0 down vote accepted

Fixed it.

The issue was the the VPN that was setup in the office used the default internal IP addresses 192.168.1.1 and the router/modem that I got from Verizon, was also setup to use the default internal IP addresses.

Once I got on the VPN and tried to connect, it was confused and didnt know which 192.186.1.1 range to use.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.