Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been running Hyperic for a few months now and for the most part I'm pretty happy with it. I have recently noticed however that the agent process seems to hog 100% of the cpu every 15 mins for about 30 secs. The servers are windows 2003, the hyperic agent is version 4.0.3. Some googling hasn't turned up much of any use. I'd appreciate any pointers as to how I might further investigate this, or suggestions for a cure if anyone else has seen the same themselves.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Sounds like Hyperic is scanning your servers every 15 minutes. What configuration settings is Hyperic checking, and can they be refined to have less of an impact?

  • You could try monitoring fewer settings on one of the servers to see if it has an effect.
  • It's also possible that another process is reading the registry and or file system at the same time as Hyperic. You might try disabling unnecessary services to see if that reduces CPU load.
share|improve this answer
    
hi, thanks for the response. I've disabled a number of the monitoring steps but it hasn't helped yet. tomorrow I'll try disabling more and see if I can isolate which is to blame. ta, Robin –  Robin Jun 4 '09 at 15:51
    
seems to be fine now, I've removed the location of the log files from the tomcat configuration. even though this was supposedly not setup to monitor these (I think) removing the log file location seemed to sort it out. We do have one v large log file in there which would fit with some comments on the hyperic forums. –  Robin Jun 4 '09 at 16:23
    
Glad to hear that worked. I've used Tripwire for server monitoring, and in Tripwire you can limit the types of file changes it checks. For log files you may only want to check for deletion / last-access time / security. –  Eric H Jun 4 '09 at 16:40

I had a similar issue with hyperic 4.1.1. After running fine for 2+ years, we started seeing high cpu use.

We isolated the issue to the agent. In our case, we were using the agent with the embedded jre.

We installed the v6 build 35 jre, and set HQ_JAVA_HOME :

(Note: Do not set this var to the java bin dir. Rather set it to the base jre6 dir, on windows this is typically: c:\program files\java\jre6 )

We restarted the agent, and there is peace on earth!

http://pubs.vmware.com/vfabric5/index.jsp?topic=/com.vmware.vfabric.hyperic.4.6/Configure_JREs_for_Hyperic_Components.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.