Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a problem .NET 4 app I'm trying to load on my IIS7 server. It has a bug where if it gets hit multiple times while it's trying to come up - either initially or from a recycle - it gets deadlocked permanently.

I'm trying to figure out a way to either prevent traffic from coming to it while it's initializing, or in the worst case make the whole thing "single-threaded" so that it can never get two requests in at the same time. I'm already running just one worker process but that's not doing the trick. Ideas? Thanks...

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Sounds like a badly written app. I'm not aware of anything you can really do aside from getting the application source looked at and fixed.

Do you have access to the source or the developer?

share|improve this answer
Sigh, arguably. It's one of those eleventh hour things where a code fix would take too long so they're looking for the sysadmin to save the day. – Ernest Mueller Nov 2 '10 at 16:55
Yep, in the end we're having to push off the release and make the dev fix it the right way. I was just hoping there was some at least temporary magic I could pull out... – Ernest Mueller Nov 2 '10 at 18:46
I'm sorry about that; I know how it is! +1 for the question though, for the effort! – Andrew Barber Nov 2 '10 at 18:57

I tried adding limits to


<?xml version="1.0" encoding="UTF-8" ?> <configuration>   <system.web>
        requestQueueLimit="5000" />   </system.web>
        <legacyUnhandledExceptionPolicy enabled="false" />
        <legacyImpersonationPolicy enabled="true"/>
        <alwaysFlowImpersonationPolicy enabled="false"/>
        <SymbolReadingPolicy enabled="1" />
        <shadowCopyVerifyByTimestamp enabled="true"/>
    <startup useLegacyV2RuntimeActivationPolicy="true" /> </configuration>


But it didn't work, it still deadlocked. Tried setting the threads to 1 as well, but then the worker process won't even start.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.