Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Windows 2003 R2 server, and its c: drive keeps filling up. When I look for what's taking the space, I see an almost-2GB EDB file:

C:\Documents and Settings\All Users\Application Data\Microsoft\Search\Data\Applications\Windows\Windows.edb

with an even bigger cousin:

C:\Documents and Settings\All Users\Application Data\Microsoft\Search\Data\Applications\Windows\Projects\SystemIndex\SystemIndex.Crwl3.gthr

I've been told that this is the database of the indexing service. I went to Services, found "Indexing service", and disabled it. I also deleted the offending large files. I also made sure that the checkbox for "Indexing Service" was unchecked in the Windows Components Wizard (Add/Remove Windows Components).

But now, some time later (a couple of weeks?), I come back and find the files are back again. The Indexing service is still Disabled in the Services snap-in. The checkbox for "Indexing Service" is still unchecked in the Windows Components Wizard.

However there is a process searchindexer.exe showing in the Task Manager, with oodles of read and write I/O.

How can I get rid of the indexing service, permanently? (But safely...) There is nothing on the server that uses it, that I'm aware of.

share|improve this question

2 Answers 2

Another thing you might want to add to your checklist is going to the properties of the hard drive itself in the general page there might be a checkbox enabled which says "allow files on this drive to have contents indexed" you will want to uncheck that and apply changes inheriting all the way through to all files and folders on the volume.

share|improve this answer
    
Good point... actually I did make sure this was turned off last time, but had forgotten about it this time. I just now looked, and it was still turned off. So, no dice... –  LarsH Nov 2 '10 at 19:26
    
P.S. I will upvote this answer but will wait a while hoping for other answers. I don't want to bump this q off the "unanswered" list yet. –  LarsH Nov 2 '10 at 19:28
    
Here is a guide more specific to Windows 7 / 2008 although it looks like it touches on this in some more depth although most of what you tried is exactly what I would have tried out. howtogeek.com/howto/28450/… –  Nick O'Neil Nov 2 '10 at 19:39
    
Bummer... it won't let me upvote this answer (vote locked in unless this answer is edited). If you edit the answer, let me know so I can upvote it. –  LarsH Nov 2 '10 at 19:40
    
good to know about the right-click menu item for "Go to service", even though it's not available in Win 2003. –  LarsH Nov 2 '10 at 19:42
up vote 3 down vote accepted

OK, I think I found the answer. I discovered there's another service, named Windows Search, on the same server, and that service was "Started". So I disabled it. The searchindexer.exe process then disappeared.

I don't know why there is both an "Indexing Service" and a "Windows Search" service on the same machine, or how they're different, but hopefully things are fixed now.

I guess we'll know for sure after next time we reboot the server. Thanks again for looking at this question.

share|improve this answer
1  
The are different versions - an old one and a replacement service. Indexing service is basically retired but there for people still needing it (for the API). Windows Search Service was installed by a patch / Service pack or so. –  TomTom Nov 2 '10 at 19:41
    
@TomTom: thanks, good to know. –  LarsH Nov 2 '10 at 21:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.