Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Apache 2.2.17 and nginx 0.8.53 as load balancer (static for Nginx and PHP for Apache). Everything is working, but when I access mysite.com (default port 80) I get my webpage and can see HTTP headers of nginx server. When I access mysite.com:8080 I get the same page and see headers of Apache2. How can I disable or redirect port 8080 to main domain?

using CentOS 5. apache and nginx are compiled from their sources.

share|improve this question
up vote 1 down vote accepted

You could bind the service that uses 8080 (apache right?) to localhost instead of your actual IP. Check for "Listen" in httpd.conf/apache2.conf, and replace with "Bind localhost" and restart the service.

share|improve this answer
    
+ changed in nginx.conf proxy_pass to 127.0.0.1 – NARKOZ Nov 3 '10 at 13:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.