Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i'm running Windows XP SP3 , in a workgroup. I need to share a folder on volume C: (FAT32 formatted) and i need this to be available in R/W to everybody, without asking for a login. I mean i dont want the login request to appear at all, and the reason is this share has to be accessed by an appliance wich cannot provide authentication.

Couldn't find anything on the internet to achieve this,

i gave "everybody" and "anonymous access" full control . I have changedv the local policy value EveryoneIncludesAnonymous as explained in KB278259

Anybody can help? i wonder if this can be done via mac/unix file services, or if trhere is some trick i dont know.. thanks for your help RadioLontrA

share|improve this question
    
What's the appliance? (or what's its OS?) If you've given everybody full control to both the share and the directory, that's the only avenue left to check. –  Kara Marfia Nov 3 '10 at 14:50
    
it's probsably linux based, but anyway i'm not allowed to work on it. The real problem is the login is requested even if i try to access the share from any Microsoft operative system. I remember in Win98 i could share a folder and open it from another machine with no need to put in a username, i'm tryin to do the same with XP or 2003 ... –  user59060 Nov 3 '10 at 15:08
add comment

1 Answer

It's been a long time since I've dealt with this on Windows, but I believe you need to enable the Guest account; Windows maps unauthenticated requests to this account by default.

share|improve this answer
    
The Guest account is enabled, but it needs the name guest to be filled in, even if no password is set.. –  user59060 Nov 3 '10 at 23:18
    
Enabling the guest account works fine for me - adding anonymous to the ACL does not appear to be necessary provided "everyone" has access. –  Nexus Dec 1 '10 at 22:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.