Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Try as I might I cannot get remote access to my install of SQL Server. I know the firewall (Windows Server 2008) is the problem, since if I drop the firewall I can connect fine. I have the port open in the firewall but still no connection. It's driving me crazy, am I miss something really obvious?

I've double checked that the port I specified is the one used to get the connection, but it's as if the firewall is just ignoring my exception...

share|improve this question
add comment

4 Answers 4

Just to check, you are using TCP port 3389 (default of RDP), right? What scope do you have the firewall rule under? If you defined the FW rule for a different scope than the OS thinks it is coming from, it won't match it. ie, if the network adapter is on a "public" scope and the rule you put in is for a "domain" scope, it won't match.

EDIT: Doh. Just realized I misread that - I thought you said remote desktop. Do you have both 1433 and 1434 UDP opened up?

share|improve this answer
    
I've set SQL Server to be listening on 2775, so I've opened the following ports: 2775, 1433, 1434 and 3389. All have their scope set to 'Any computer'. Still no connection through the firewall. I am connected to a domain, could this be relevant? –  mattyB Nov 4 '10 at 8:29
    
What about on the "Advanced" tab of the firewall rule.. which profiles are selected? Does the SQL server only have one network interface? –  Dan Nov 4 '10 at 12:25
    
Set to [tick]Local Area Connection. The server is a VM, only has one network connection. –  mattyB Nov 5 '10 at 12:12
    
And under that Advanced tab, which profiles are selected? –  Dan Nov 5 '10 at 12:50
    
Firewall Settings > Advanced tab > just one Network connection listed, Local Area Connection (selected) –  mattyB Nov 5 '10 at 13:24
show 5 more comments

Can you post your full rule? We're kind of grasping at straws here.

share|improve this answer
add comment

Are you connecting via Named Pipes or TCP/IP? TCP/IP will require port 1433, but Named Pipes use the standard Windows RPC mechanism and require ports 139 and 445 to be open.

share|improve this answer
add comment

Do you created an inbound rule for port TCP 1433? I have the same problem a few days ago at work because I created by mistake an outbound rule (I didn't realize that until the next day...).

Also, if your server don't use the default instance (e.g. you access the server using servername\instance instead of jus servername), you need to allow access to the SQL Server Browser too (UPD 1434).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.