Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up a user on our staging server for the reporting services to use for its required tasks. Or at least I thought I did. I made a couple of grave errors:

  1. I did not exempt it from the password policy
  2. I did not allow it permission to start the Reporting Services service.

Because of 1, when the password expired all reports defaulted back to trying to use my dev Data Source instead of the Data Source I had configured on the server. I updated the password but this seemed to make no difference. (I am assuming that it was the password expiry that triggered this permissions fault, and that it is a permissions fault, the behaviour is that the reports no longer seem able to see shared data sources anyway. I am happy to hear about anything else that may cause this.)

Because of 2 when I tried to restart the service it failed. So to get it running at all I had to change the service account to a built in one. However then it can't access the database, I would rather the Reporting Services Account had permission to start the service, how do I grant it that privilege?

share|improve this question

For the user you could either edit their password policy through the Computer Management interface if it's local or through the Users and Computers interface if it's a domain account.

Try adding the user to this group:


That should give them access to be the logon account for Reporting Services. It is created locally on any machine that has Reporting Services installed on it.

share|improve this answer
Hi, I had to add the user to that group when I first configured RS. Thanks for trying though! – One Monkey Nov 4 '10 at 10:16
up vote 0 down vote accepted

This is all related to the issue described in this question on Stack Overflow. I tried this chap's answer and for me, no dice, but hopefully someone may find that useful. My server is obviously in a more parlous state.

EDIT: After a lot of wailing and quite a bit of gnashing of teeth I found that simply setting up a second identical gofer account for SSRS and configuring the Server to use that instead resolved all my issues. Before I did this I remembered that there was also an identical user account on the live data server but updating the mirror of the original account left the SSRS not knowing what to do with its keys. The new user, on the other hand, soothed its confusion and cleared up all the problems. I don't exactly know why this should be but SSRS sure does get upset if its gofer account undergoes a password change.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.