Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ok guys Im sure this is a pretty simple solution but im not exactly sure what the answer may be. I have setup a lab. 6 server 2003 Standard installs and 1 server 2008 install. I have 2 Dcs and the rest are all member servers including the 2008 box. On DC1 i have 2 NICS installed one is set for external (suto configures via ISP) and one is the internal one (all internal IPs are hard coded no DHCP in use) DC1 has DNS service running on it as well and also has RAS (nat option) intalled on it. All member servers have a hard coded ip in the range of 10.0.0.2 - 7 the DC1 is set to 10.0.0.1 on the internal NIC.

For the gateways on the member machines i have set no gateway and point the DNS on the nics to the IP of DC1.

Heres what does work. From DC1 i have internet access. from any member server i do not get internet access. If i do nslookup from the member servers it does resolve a name to an IP address. (this tells me DNS is working) if i ping something on the internet it resolves the IP but gets destination not reachable (which i believe means routing is not working correctly).

Long story short the internet is not accessable from the member servers and i believe there is an issue with my routing. I ran the NAT setup under RAS install and just did the defaults. I then added my ISP's DNS to the DNS forwarder on my DC1's DNS settings....

Sorry if i rambled and didnt make sense id be happy to clarify or include info that may be needed...

Thanks in advance.

share|improve this question
    
Try adding a default gateway to the member servers –  GregD Nov 3 '10 at 17:44
add comment

2 Answers 2

For the gateways on the member machines i have set no gateway

That would be exactly why you can't ping outside the subnet -- the gateway is the default route, and you don't have one.

share|improve this answer
    
But i was told in a natted environment you leave the daefault gateway blank... is this only when the RRAS server is also handling DHCP or something... Even Microsoft says to not use a GW.. See here support.microsoft.com/kb/816581 –  Sentin709 Nov 3 '10 at 17:57
    
@Sentin709, that article is talking about the inside interface on the dual-homed computer that is doing the NAT. The NAT-router should only have a gateway set on the interface connected to the Internet. The clients will need a gateway. The article suggests you use DHCP for the client machines which would set the gateway for you. –  Zoredache Nov 3 '10 at 18:18
    
Okay So should i set the gateway on my member servers as the internal NIC ip address on the RAS / NAT box. Sorry but im terrible with networking / routing and i do appreciate your help! –  Sentin709 Nov 3 '10 at 18:21
    
Well i added the gateway on the member server as 10.0.0.1 and I still get page not displayed.... I can still do an NS lookup and it resolved i can ping an outside address and it resolves but gives destination unreachable. I believe it still a routing thing as i can resolve but not ping.... Do i need to add some static routes to the RAS server.... I had assumed it would add the one internal to external nic as a route! –  Sentin709 Nov 3 '10 at 18:42
add comment

Found out what the problem was. I was using a PAC file to autoconfigure the proxy. Apparently there was an issue with using this on the member servers through the gateway... It worked fine on the gateway... After entering the proxy manually Voila it works... Damn automation!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.