Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed NX Server on Ubuntu Maverick Meerkat (10.10) using the instructions found here: https://help.ubuntu.com/community/FreeNX

I have a problem using the default NX Client for OS X (10.6) downloaded from the nomachine website.

When using the OS X client, every time I hit the lowercase d key in the NX session window whatever remote window I'm using minimizes. This only happens in OS X, from the Windows client I have no such problem. This happens from two different OS X machines, so it's unlikely to be a local setting.

share|improve this question
    
It turns out lower-case d is minimizing ALL applications. Upper-case D works normally (i.e. inserts 'D') –  Jonathan Nov 3 '10 at 18:40

5 Answers 5

up vote 5 down vote accepted

Solved it. NX client seems to assign it's own shortcuts - but only on Ubuntu 10.10 does it assign minimize all windows to the 'd' character. Change it server side when logged in via the NX Client and the problem is fixed.

Under Settings > Key Mappings > Minimize All Windows. It won't let you disable it, so just choose a key combo you'll never use (I chose Ctrl + D.)

share|improve this answer

You can disable it by 'assgining' Backspace as the new shortcut.

share|improve this answer

I had this problem in Ubuntu 10.10 too. Whenever I pressed d on the keyboard it minimized all the windows. I fixed it by going into System --> Preferences --> Keyboard Shortcuts and disabling the shortcut that was setup to use the D key press.

share|improve this answer

The setting I had to disable d for in Ubuntu 10.10 was "Hide all normal windows and set focus to the Desktop"

As Kyle said in another reply, use Backspace to disable the shortcut

share|improve this answer

The above didn't work for me but the tip here did for Ubuntu 11.10. After I made the change, I had to restart.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.