Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to join my windows 7 desktop to our companies domain. The domain is all set up and other win7 boxes are joined to the domain OK. When I try to join the domain, I get prompted for credentials, I enter the valid credentails, and then get the error "The network was was not found".

It seems that DNS servers are a common cause of this, so on IPConfig /all I can see I have a valid looking connection-specific DNS suffix, and I have 2 IPs in my DNS servers list (the same as another PC I looked at that is on the domain). I changed the ipv4 config to explicitly use these DNS server IPs rather than obtain automatically, to no avail.

I can access computers on the network (I get prompted for credentails which then works), its just joining the domain that doesn't work.

I'm not very skilled at AD / network issues so it might be something obvious ;)

[UPDATE]

It seems that we're using google public DNS (8.8.8.8) instead of one on our server. So the problem is likely to be that when trying to join the domain, the computer is using google to try and find the server FQN - which it isn't going to find. Is there a way round this? I tried changing the DNS server to the IP of the server, but it doesn't like that.

share|improve this question
add comment

3 Answers

First, get rid of the connection specific DNS suffix.

Second, is your machine configured to use the DNS servers that are responsible for the AD DNS zone? It's hard to tell from what you've stated.

share|improve this answer
    
Sorry, I'm a bit lame with this. I unticked "append parent suffixes of primary DNS servers" but that doesn't appear to remove the suffix. As for the AD DNS zone, I asusme that is the case because I checked a PC that is on the domain, and is using the same DNS servers (it also has 127.0.0.1 which I assume I don't need to worrry about) –  Matt Roberts Nov 4 '10 at 12:06
    
Where are you seeing the DNS suffix, in the "DNS suffix for this connection" field? If so, just delete it from that field. –  joeqwerty Nov 4 '10 at 12:24
    
No I only see that when I issue "ipconfig /all" - I don't see it anywhere else.. –  Matt Roberts Nov 4 '10 at 12:27
    
OK, it sounds like this is being set by the DHCP server then. Does the DNS suffix in ipconfig/all match the AD DNS suffix? –  joeqwerty Nov 4 '10 at 12:31
1  
THE AD DNS server should point to itself for DNS and the AD clients should point to the AD DNS server for DNS. That's the only way it's going to work. –  joeqwerty Nov 5 '10 at 11:09
show 3 more comments

Then you'll want to setup Googles DNS Servers as 'Forwarders' inside the AD DNS Settings, so that way anything your servers can't resolve, Google DNS will take over.

http://technet.microsoft.com/en-us/library/cc754941.aspx -- This link will walk you through that process.

share|improve this answer
add comment

Another thing to check: ensure NetBIOS over TCP/IP is enabled on the server. Disabling this prevented me from adding new machines in the domain

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.