Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to install .NET framework 3.5SP1 on Windows server 2008R2 64 bit server, but windows is not allowing me to do this manually. I tried to do this with Windows Update, but Windows update is stuck in downloading, at 0%. Please help

share|improve this question

2 Answers 2

Please notice that the Setup Process for .NET has changed in 2008 R2. There is also a MSDN Blog Entry outlining the current procedure.

So following there example let's make sure .NET is correctly installed. Therefore you can issue these Powershell commands:

Import-Module ServerManager
Get-WindowsFeature | Where-Object { $_.name -eq "as-NET-Framework" } | format-list Displayname,Installed

Check that it says Installed:True. If the .NET Feature is not activated you can do so by issueing:

Add-WindowsFeature as-net-framework

If the feature is installed, and the problem with downloading persists you could try removing and reinstalling the .NET Framework from Scratch (uninstall the Feature, reboot, reinstall) and update with a clean installation.

share|improve this answer
    
the feature was installed, and finally formatting and reinstalling solved the problem. Thanks –  RaSiN Nov 5 '10 at 12:48

Try using System Update Readiness Tool. It tends to help in similar situations where updates are broken, stuck or failing all the time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.