Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently installed sphinx, mysql etc. and everything works fine as well. However, I always get the message:

Sphinx cannot be found on your system. You may need to configure the following settings in your config/sphinx.yml file:

  • bin_path
  • searchd_binary_name
  • indexer_binary_name

For more information, read the documentation:

I configured the bin_path in sphinx.yml to

development:
  bin_path: '/usr/local/bin'
  searchd_binary_name: 'searchd'
  indexer_binary_name: 'indexer'

With no success. How can I get rid of that message?

Thanks in advance!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Setting the bin_path ought to do the trick. You shouldn't need to specify the commands.

If you installed with mac ports, sphinx may be in /opt/local/bin

Try a 'locate searchd' from the command line to make sure you are looking in the right place.

share|improve this answer
    
I uninstalled the version built from sources and installed it out of the mac ports tree, now it works. Thanks. –  Patrick Nov 29 '10 at 20:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.