Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install an application on a MAC 10.6.4, however i get an installation error that no java runtime environment.

However on the java website, the mac section indicates that MAC provides its own java and should use the software update software to get the latest java application. I have done this and gotten the latest java however I still get the same error no java run time

is there something am missing?

share|improve this question
    
I'm sensing that you might be trying to install OpenOffice? If that's the case, don't worry about it. The installer threw that error for me and it still works. I imagine it simply doesn't correctly detect the JRE. Also: migrate to Superuser? –  msanford Dec 10 '10 at 17:56

1 Answer 1

up vote 1 down vote accepted

One thing that comes to mind is that this might search for an old JRE and doesn't work correctly with the JRE v6 installed on Snow Leopard.

Just to confirm that you have Java installed and working, you could try to start it, i.e. with the command java -version in Terminal.app.

share|improve this answer
    
This is what i have as the version "java version "1.6.0_22" Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-10M3261) Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)" –  Gatura Nov 4 '10 at 12:06
1  
So, Java is in fact installed and working. Do you see any hints re. the required Java version in the docs of the program in question? Also, what is the program you try to install? –  Sven Nov 4 '10 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.