Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a machine here that's running a website. It's only really a development machine but it has IIS on it for testing purposes. Problem is that when pages get loaded in internet explorer using the machines name, the request is going out to the proxy server which is coming back with an error:

The requested URL could not be retrieved


While trying to retrieve the URL: http://seed-dev1.hull.ac.uk:5555/

The following error was encountered:

Unable to determine IP address from host name for seed-dev1.hull.ac.uk The dnsserver returned:

Name Error: The domain name does not exist. This means that:

The cache was not able to resolve the hostname presented in the URL. Check if the address is correct. Your cache administrator is webmaster.


Generated Thu, 04 Jun 2009 16:18:33 GMT by slb-webcache-east.hull.ac.uk (squid/2.6.STABLE22)

The error makes sense as the machine is really seed-dev1.net.dcs.hull.ac.uk. Regardless, I don't want it to be going off to the proxy server for local addresses. Not only is 'Bypass proxy server for local addresses' ticked on the proxy settings, but I've added exceptions in addition so it shouldn't be using the proxy for addresses beginning with: '*.hull.ac.uk; localhost; 127.0.0.1; seed-dev1' I can confirm that the exceptions are at least working because I can get to any pages within hull.ac.uk which I wouldn't be able to if I hadn't put it in the exception list.

As that doesn't work, I went further by going to the hosts file at C:\Windows\system32\drivers\ect

and added a line changing it to:

127.0.0.1 localhost 127.0.0.1 SEED-DEV1

A quick restart and it still doesn't work. Any pages that I try to access using the machine name just get that bad page returned from the proxy. Using localhost is all well and good for a single page but then you click on a link and it just switches back to the machine name in the url.

Any suggestions of stuff I could try would be much appriciated

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Let's try the easy ones first:

(In Internet Explorer; and I'm assuming you're using IE because you're running IIS on 127.0.0.1 and you reference the hosts file in \drivers\etc.)

1.) Navigate to "tools", "internet options", "connections", "LAN Settings".

2.) Make sure, "Bypass proxy server for all local addresses" is selected.

Now, hmm. Assuming you're running an internal DNS server/private IP addresses:

3.) In a command-prompt, run: "ipconfig /registerdns"

4.) Ensure that you can forward and reverse ping your machinename w/ it's internal IP address.

5.) If "localhost" isn't working, try pinging localhost at the command prompt, it's resolving to 127.0.0.1, yeah?

Let's clean up that hosts file:

5.) Make sure your hosts file wasn't inadvertently saved with a ".txt" extention. If so, remove it.

6.) In your LAN/adapter settings, make sure that you don't have any DNS suffixes to be appended.

Curious to see if any of those fixed the problem..

share|improve this answer

Check your IE Zones - I've seen it happen at times that IE would place a local server in the Internet zone, thus causing it to ignore the "bypass proxy" setting. Haven't figured out the reason why yet, but it does appear related to either a non-standard port or the server not being a member of the same Windows Domain as the client. To be honest, this is not something I've spent too much time researching; once I found a solution I moved on.

You should be able to explicitly add this server to your Intranet zone and thus trigger the proxy bypass; otherwise you will need to explicitly add the FQDN of the server to your "bypass proxy" list.

share|improve this answer

In the early days of IE, a local server was defined to be "a server without periods in the name". in your example "http://seed-dev1/" would be local and "http://seed-dev1.hull.ac.uk:5555/" would be remote and sent to the proxy server.

In the IE Internet Options dialog, click on the Advanced button next to the port number text box for the proxy setting. You should see a text box at the bottom of this new dialog box that allows for exceptions. Try entering seed-dev1.hull.ac.uk in that box and clicking the OK buttons until you get back to the main IE window.

thanks, mark

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.