Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ok, bear with me, this is kind of hard to explain.

I have an AIX server (5.3.9.0) that is running apache 2.2.11. With static files (css, html), I can upload a file to the server, and when I call it, either directly or not, it doesn't show me the updated file, for at least 10 minutes. Then it appears. The apache modules mod_cache, mod_mem_cache and mod_disk_cache are installed, but I have disabled the cache in the httpd.conf file (passes syntax check as well), and it continues to be a problem.

Any ideas what I need to change? The server loads php and cgi files perfectly fine.

share|improve this question
    
Just after posting we found the fix... in your httpd.conf file add: EnableSendfile Off' –  user59197 Nov 4 '10 at 15:05
    
You should post your fix as an answer then come back in a couple of days and mark it accepted. –  Dennis Williamson Nov 4 '10 at 15:59

1 Answer 1

Setting EnableSendfile to off in httpd.conf e.g.

Enablesendfile Off

solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.