Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently running snv_129 (EON NAS image). I think I have somehow shorted one of my PHYs and I'm trying to debug the issue.

/etc/hostname.rge0 192.168.250.20 /etc/hostname.rge1 192.168.250.21

Router: 192.168.250.1 Network 192.168.250.0/24

I'm trying to switch the active/primary NIC from rge0 to rge1 and am unsure how to go about doing this (I really should have stayed with Linux, which I know a whole lot better).

Anyhow, netstat -rn gives me this:

Dest: default GW: 192.168.250.1 flags: UG 127.0.0.1 127.0.0.1
192.168.250.0 192.168.250.20 Interface: rge0

I cannot ping anything when using rge0 as the primary interface. I don't really have the skills with Solaris to know how to debug this issue.

svcs -a says everything is online, and I can ping 192.168.250.20 whether it's plugged in or not.

Any help would be appreciated, and I'm happy to add more information if necessary

EDIT:

My eventual goal was to do link aggregation. At this point, all I want is to return one of the two interfaces to functioning order - just one.

I've followed some of the advice below. Here is what I've done since last update:

Disable interface 1 in the BIOS. (only one interface detected)

dladm show-phys:

LINK: rge0 MEDIA: ethernet STATE: down SPEED: 1000 DUPLEX: full DEVICE: rge0

ifconfig rge0:

flags: UP BROADCAST MULTICAST IPv4 (RUNNING is not present) inet: 192.168.250.20 netmask ffffff00 broadcast 192.168.250.255 ether ff:7f:7f:7f:7f:7f

Anybody have any ideas on next steps?

share|improve this question
    
"ifconfig -a" would be a good start. What are you trying to achieve with two physical interfaces on the same LAN ? –  jlliagre Nov 4 '10 at 23:51
    
Once upon a time, I was hoping to do link aggregation, but for now I'll settle for just getting one of the two interfaces to work. I can't cut and paste from the machine (no network), but i'll try and get the relevant info posted. –  darthcoder Nov 5 '10 at 0:56

3 Answers 3

I've never tried putting IPs into hostname.XX; typically the file has a hostname, and /etc/hosts maps the host name to the IP for that interface. Swap the hostnames listed in the per-interface files and reboot, and presto, swapped interfaces. (Or swap in /etc/hosts, but that could break more things.)

share|improve this answer
    
I think part of my problem is that the networking layer creates routes to rge0, and not rge1, and I'm not sure how to change that. –  darthcoder Nov 5 '10 at 2:56
    
Unless there are explicit modifications to the routing table (/sbin/route in rc.local?), or you're running something doing RIP/OSPF/etc, swapping the hostnames should swap the path to the gateway, and thus the path to points further distant. Routing directly to an interface doesn't work so well, at least on Ethernet. –  techieb0y Nov 5 '10 at 23:22

It's not clear what you are trying to achieve. If it's only testing basic IP connectivity with both interfaces I suggest you leave the standard system configuration aside and work with dladm/ifconfig directly.

Disable the SMF service so it doesn't interferer with your testing (svcadm disable physical:default)

Unplumb both interfaces (ifconfig rge0 unplumb; ifconfig rge1 unplumb)

Now configure rge0 and test it (ifconfig rge0 plumb; ifconfig rge0 192.168.250.20 netmask 255.255.255.0; ping your gateway). Remember to unplumb it after you determined it's working.

Now configure rge1 and test it (ifconfig rge0 plumb; ifconfig rge1 192.168.250.21 netmask 255.255.255.0; ping your gateway). Remember to unplumb it after you determined it's working.

Review the standard configuration (/etc/hostname.if /etc/defaultrouter /etc/netmasks) and re-enable the physical:default SMF service.

I don't think you can have two interfaces on the same subnet without some special routing or IPMP.

share|improve this answer
    
I've updated my question with additional info - I'm not trying to have two interfaces on one network - I'm just trying to get one of the two working. See above, I've disabled one of the PHYs in the BIOS. –  darthcoder Nov 10 '10 at 3:18
    
Does any LED light up in that interface? I ask this because dladm is showing it as 'down' for some reason. You MAC address is also very different, perhaps you have a faulty interface. Overall, dladm has to show it as up, you ifconfig it (or configure it through the files/SMF) and we're done with it. –  gtirloni Nov 10 '10 at 21:27
    
Try to do a reconfigure boot (touch /reconfigure; shutdown -y -g0 -i6) and see what interfaces are left (both in dladm and /etc/path_to_inst). You might loose network access to it. –  gtirloni Nov 10 '10 at 21:28

If you want both interfaces to work, you should enable ip multipathing (IPMP). Having two network physical interfaces in the same broadcast domain is unsupported and might lead to various issues with either Solaris or Linux, including the one you are experiencing.

share|improve this answer
    
This is eventually my goal, when I get a switch that supports link aggregation. Now, I'd just be happy getting one of the two interfaces working. –  darthcoder Nov 10 '10 at 3:21
    
You are confusing IPMP and aggregation. IPMP doesn't require anything specific from the switch. –  jlliagre Nov 10 '10 at 9:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.