Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I edit the crontab using crontab -e it opens the crontab in vi. I'd prefer it to use nano. How can I change this?

EDIT:

For some reason the export command returns command not found. And changing the EDITOR env value didn't work for crontab -e.

The following command worked on my system:

setenv VISUAL /usr/local/bin/nano

share|improve this question

4 Answers 4

up vote 6 down vote accepted

For sh based shells:

export EDITOR=/path/to/nano

For C shell based:

setenv EDITOR /path/to/nano

Remember that unless you save these setting to your login profile script (/home/user/.bash_profile for example), you lose the setting at log out.

If I remember correctly, FreeBSD uses C shell as the default user shell.

share|improve this answer
    
As a note, csh uses ~/.cshrc for the profile script, so you'd need to put the setenv command in there. –  hark Jun 4 '09 at 17:33

Should be

export EDITOR=/usr/bin/nano

adjust for your location of nano (use 'which' to find). You can put that command in your .bashrc or similar profile script to have it in effect all the time.

share|improve this answer

Probably by setting the environment variable EDITOR.

I.e.

export EDITOR=/path/to/nano
share|improve this answer

There is a symbolic link under /etc/alternatives/editor that can be pointed to /path/to/nano

You can use the update-alternatives utility to do this as well - although I am not too familiar with using it.

(note - I'm speaking from an 'ubuntu' point-of-view. not sure if this is the same for FreeBSD)

share|improve this answer
1  
It's not the same for FreeBSD. –  hark Jun 4 '09 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.