Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There has been another question like this logged before,, however it was never really resolved.

I have multiple instances of postfix running on one server, which all generally seem to send perfectly. However i am occasionally getting the following error:

Nov 5 12:35:21 cp postfix-ms00/smtpd[18550]: connect from[] Nov 5 12:35:21 cp postfix-ms00/smtpd[18550]: disconnect from[]

Basically it connects and then disconnects immediately.

When i run tcpdump -s0 -X -i eth0 port 25 and host and the connect/disconnect error occurs nothing gets outputted.

Does anyone know how i can fix this?

is there a way i could watch the smtp command output? i.e: the "helo localhost" information when the mail is trying to be sent.

share|improve this question

You could enable postfix debugging for specific hosts.

debug_peer_list =
share|improve this answer
Thanks i figured it out. It was an authentication issue. – user59308 Nov 8 '10 at 15:16
Mark the question as solved then. – Konrads Nov 22 '10 at 10:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.