Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When saving my 90KB text in a LONGTEXT field (using phpmyadmin), nothing happens. Anything above around 64KB doesn't seem to get saved.

I tried to reproduce the same behavior on another server but there it worked, so some setting on my server must be preventing it from saving packets above the 64KB threshold.

Nothing seems to be wrong in the MySQL config file:

 key_buffer       = 16M
 max_allowed_packet   = 16M
 thread_stack     = 128K
 thread_cache_size    = 8

Any idea what the issue could be?

share|improve this question
    
I'd be more inclined to suspect PHPMyAdmin as the culprit, rather than MySQL. I suggest you verify that via the command line (if possible). –  John Gardeniers Nov 6 '10 at 1:11

1 Answer 1

up vote 1 down vote accepted

Did you update the other server via commandline? Or with the same browser / phpMA combo?

Most likely, you are using a textarea to update this field, and most browsers AFAIK will only support sending a maximum of 32KB in that fashion, which is why your data is being truncated.

There is a phpMA config variable, namely $cfg['LongtextDoubleTextarea'] = TRUE that will double the available editing space, however this seems to be already present (32 -> 64KB).

Easiest workaround is simply to insert manually or with a script.

share|improve this answer
    
Thanks for the reply. Unfortunately, none of your suggestions seem to fix the issue. I've tried with a script as well, saying no rows have been affected. (Same with phpMyAdmin, I'd usually get 1 row affected after updating a row with a small chunk of text, but no rows affected when I try with my 90KB text.) –  Laurent Van Winckel Nov 5 '10 at 22:08
    
Anything in the PHP or MySQL error logs? –  Sam Halicke Nov 5 '10 at 23:01
    
I found this in my PHP log: "ALERT - configured request variable value length limit exceeded - dropped variable 'content'". After googling that, turns out the Suhosin extension I have installed on the server is limiting the POST value size. I change the following config lines to a higher value: "suhosin.post.max_value_length = 65000", "suhosin.request.max_value_length = 65000". And it worked! Thanks for the help :) –  Laurent Van Winckel Nov 6 '10 at 0:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.