Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to checkout my company's existing code repository in order to add my iPhone project to it. Up until now, all development has been done on Windows, so I'm using the first Apple ever to try and access our svn server.

The problem is, every time I try, either through command-line using
svn co svn://server_name/
OR
svn co svn://xxx.xxx.xxx.xxx/
or with both addresses through SCPlugin, I get "Can't connect to host 'server': Operation timed out"

On my windows machine I have a local copy (being managed through TortoiseSVN), with which I can update, commit, and browse the repository with no issues.
On my mac, I can ping the server and even access the filesystem via Finder.

I have also tried checking out sub-directories, e.g. svn co svn://server/project/trunk/, and that gets the same result.

Any ideas?

share|improve this question

migrated from stackoverflow.com Nov 6 '10 at 0:38

This question came from our site for professional and enthusiast programmers.

1  
Sounds like a firewall issue rather than a SVN one. More suited on serverfault.com I think, voting to migrate there –  Pekka 웃 Nov 5 '10 at 16:10
    
I thought about it being a firewall issue, but I find it odd that a firewall would stop a mac, but not a windows pc, even when they're using the same ethernet cord. edit: IT guys next door are not aware of any internal firewalls that would be causing this. –  Zind Nov 5 '10 at 17:17
add comment

2 Answers

The problem might be on the svn client is installed on your mac. Check if its the same version of your windows. If it is, check if the configuration files ('.server', 'svnserve.conf', etc., they are on your svn installation folder) are set the same way.

If that can't help you, try reinstalling the svn client (not the SCPlugin, but the SVN itself).

share|improve this answer
add comment

The problem appears to be with the local DNS not playing nice with the Mac, thus forcing it to go out to the Internet to find our server.

Can't believe I didn't think to check traceroutes before posting this question x_x

The overall problem hasn't been fixed (yet; this one makes more sense to me so I have high hopes), but svn isn't the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.