Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My experience has been (on older setups) that I can remote into a system, edit a text file (*.config, *.aspx, *.ashx, etc...) in Notepad and save it.

I am unable to do this on the new box. I don't know whether it has to do with IIS7 or Windows 2008 or something entirely different.

How can I set things up to allow quick Notepad edits of files being served by IIS7?

(AFAIK, I have full permissions on the file. It is not marked read-only.)

Using Notepad, when I try to save it says "Cannot create the C:\inetpub\wwwroot\myfile.config file. Make sure that the path and name are correct."

share|improve this question
What kind of error message are you seeing? – Evan Anderson Jun 4 '09 at 17:39

It's UAC kicking you down. Non-elevated processes basically have no rights in the INETPub directory structure.

What we do on all our W2K8 boxes is install a folder on the desktop with 3 shortcuts in it - CMD (elevated), Explorer (Elevated) and ProcExplorer (Elevated). Each admin then right clicks them and selects "Pin to Start Menu".

UAC is quite painful with access issues - the error messages are standard "Access Denied" errors rather than "UAC is preventing access" errors, which is confusing as all get out. I don't know how many times I've logged on to a "broken" box where the admin has granted full rights to Everyone in an attempt to fix this w/o knowing it's UAC overriding the ACLs.

Notes: To get explorer to work as elevated, you need to edit the folder options and check "Launch folder windows in a separate process". Or run this REG file:

Windows Registry Editor Version 5.00

share|improve this answer

Try running Notepad as an elevated program ("Run as administrator"). This also applies to Vista and Win 7.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.