Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

...instead of sftp
Right now ftp-ing to my server works great with sftp over port 22, but there are times when i'm on my home network and don't need the extra ssh layer. Also, I suspect that not being able to connect on regular ftp:21 is constantly making a backup program timeout
Here's my config:

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
anon_upload_enable=NO
anon_mkdir_write_enable=NO
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_file=/var/log/vsftpd.log
listen=YES

pam_service_name=vsftpd
tcp_wrappers=YES
max_clients=4
max_per_ip=1
listen_port=21
pasv_enable=YES
share|improve this question

2 Answers 2

Make sure you allow FTP through your local packet filter (firewall). Edit /etc/sysconfig/iptables or run system-config-firewall.

share|improve this answer

A Simple VSFTPD.conf allowing login from local users.

# No anonymous login
anonymous_enable=NO
# Let local users login
# If you connect from the internet with local users, you should enable TLS/SSL/FTPS
local_enable=YES

# Write permissions
write_enable=YES

# Chroot all Users
chroot_local_user=YES
chroot_list_enable=NO

Remember FTP Passwords are transferred unencrypted. Read up on enabling SSL/TLS/FTPS.

share|improve this answer
    
Somehow this still doesn't allow me to connect, it times out. Does filezilla allow non sftp connections? does vsftpd ? –  Blackbird57 Nov 6 '10 at 21:58
    
Simple question: Did you start it? ps aux | grep vsftpd –  pacey Nov 6 '10 at 21:59
2  
vsftpd does not handle the sftp connection - SSHD does. You probably forgot to start vsftpd. Both vsftpd and filezilla allow non sftp connections. –  pacey Nov 6 '10 at 22:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.