Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have problems accessing my website, ping to the site works and has no lost data but direct access gives me a no route to the server available !?? how could ping works if there is no route to the server !?

anyone has a solution for this?

Thank you!

share|improve this question
Try "telnet 80" –  Khaled Nov 7 '10 at 14:10

3 Answers 3

Ping usually uses ICMP whereas web access uses HTTP over TCP. So it is possible that some firewall or filter is blocking one but not the other.

Are you sure the webserver is running, is listening on the port you expect (80?) and does not have any allow/deny rules that are blocking access?

Are you using a hosting provider? Do they have a help desk? Are they still in business?

share|improve this answer

To expand on RGB's answer, this is almost certainly a firewall issue, because I can reach the ssh port on the server, too:

[madhatta@risby ~]$ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=54 time=112 ms

[madhatta@risby ~]$ telnet 22
Connected to
Escape character is '^]'.

[madhatta@risby ~]$ telnet 80
telnet: connect to address No route to host

and in the last case, that answer is immediate, so it's not an ARP timeout (wasn't likely anyway). It's not DNS, because the same address is displayed each time. Check your local firewall with iptables -L -n -v and ensure that incoming TCP traffic to port 80 is allowed. If it is, take it up with your ISP.

share|improve this answer

Unfortunately, your browser and your OS can use different DNS resolvers in certain cases. What OS are you using? Can you try a different browser? Does 'nslookup' agree with the IP address that ping is showing? How about traceroute? Your browser or machine may have cached DNS.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.