Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to get an installation of SQL Express 2008 working, but no matter what I do I can't connect to it with management studio.

I've enabled TCP/IP for the instance. I've tried connecting with machinename\instance, .\instance, (local), etc etc etc. Nothing works, and I always get the same message.

If I browse for a server, the only server listed is the local integration services, which I can connect to just fine.

The SQL server service is running (SQLEXPRESS), SQL Server Agent is not (and won't, can't enable it), and SQL Server Browser is.

Anyone have any suggestions on where to go next? I've tried uninstalling EVERYTHING sql and reinstalling, no change.

share|improve this question

3 Answers 3

I'm shotting in the dark without knowing the exact error message and the authentication method (integrated or SQL Server), but you could try install it to the default instance instead of using SQLEXPRESS, it simplifies the connection and you don't need to have the SQL Server Browser service enabled.

Note that AFAIK you can only change the instance at installation time, so you would need to uninstall and install it again.

Edit based on new information:

The error you described usually means that the servername/IP is not found or that the SQL server port is blocked by a firewall (or when the service is not running, which is not your case).

Try connecting using just "localhost" or 127.0.0.1, and if this not work, check if your Antivirus/Firewall is blocking the port (you can use an utility like ZenMap (Download) for checking if port 1433 is open).

Also, do you added your Windows user to the list of administrators when installing SQL Server? This is necessary for connecting using Windows Authentication (previous versions of SQL did this automatically).

share|improve this answer
    
It was installed as the default instance, not a named one. The error I'm getting is: 'A network-related or instance-specific error occured while establishing a connection to SQL server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)' –  user59483 Nov 8 '10 at 2:41
    
I added my windows user account as well as the SA account. I've tried all the connection methods with both accounts. The only thing I haven't tried is the firewall/AV. Will that actually cause a problem even when the SQL service is running on the same machine as management studio? I'll give it a try anyway, definitely can't hurt! –  user59483 Nov 8 '10 at 12:27
    
I believe it will cause an issue with connections over TCP/IP but not over Named Pipes. –  jgoldschrafe Nov 8 '10 at 13:09
    
The firewall shouldn't be an issue in local connections, but some security solutions use configurations that could block some connections in certain situations (I have a recent experience with the free edition of an AV blocking all HTTP traffic in the network shield was enabled). –  Alberto Martinez Nov 8 '10 at 15:41

I've added a rule to the firewall, still no luck. I'll try disabling my AV software, but I don't think that's blocking it.

At this point, I think I'm going to remove everything 2008 and install 2005. I don't need any new functionality in sql 2008, so it can't hurt either.

share|improve this answer

Have you tried looking at your settings under the SQL Server Configuration Manager and going to SQL Server Network Configuration | Protocols for MSSQLSERVER? Verify that Named Pipes and TCP/IP are enabled. I remember having to manually turn this on for a couple of installations, not sure why it's not on by default.

share|improve this answer
    
Named pipes and TCP/IP are enabled, they weren't originally, but I enabled them a couple days ago. One other thing I noticed is that in the properties for sql server, sql agent and sql browser there is a field for (running on x64), which I tried setting to yes, but as soon as I press apply and ok, then go back it resets to no. Not sure if that has anything to do with this though. –  user59483 Nov 8 '10 at 23:09
    
Hmm that seems to be an option that was just added in R2, doesn't appear on my R1 install. I did just go ahead and install R2 express on my laptop to check this out and it has the same behavior. I'm going to assume this is merely a limitation of the express edition. I was able to connect using <machine>\SQLExpress as the server name, even when SQL Browser was stopped. Perhaps a next step is to run the configuration check utility. This is included with the installer that you downloaded. Run the installer again and it will be listed under Tools, it should also be in the start menu. –  Diffuser Nov 9 '10 at 15:39
    
The config checker didn't find any issues. I removed everything sql 2008 related and installed 2005, worked first try. –  user59483 Nov 10 '10 at 1:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.