Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This has been asked previously by this question but the solution that worked in that case doesn't work for me.


Using Exchange 2003. A user with two email addresses now needs to be able to send as either address. The second address was removed from that account and a new account has been created for that address. The user has been given send-as permission and has been set as a delegate for the second account.

The second account was logged into and test messages were successfully sent to several destinations, both internally and externally.

The Problem:

The user who needs to send as the second account receives the error message "You do not have permission to send to this recipient" for any test message, including those to the same recipients as were used in the first test.

There is nothing in the system logs on the Exchange machine to throw any light onto this and I can't think of what else to try. It makes no difference whether this is tested via Outlook 2003 or 2010 or OWA. Other accounts used to and for send-as work fine with the same setup.

share|improve this question
up vote 3 down vote accepted

I haven't noticed any problems with adding Send As permissions recently, but I do recall a couple of times when it seemed to be just a matter of time, as this article suggests: the new permissions aren't applied right away, so you either have to restart the information store, or just wait.

share|improve this answer
I've now waited about 20 hours and still no change. – John Gardeniers Nov 8 '10 at 20:58
After rebooting the Exchange server and waiting a bit longer the send-as now works, making this the nearest correct answer. – John Gardeniers Nov 9 '10 at 21:56
Restarting the information store kills cached data and renews all users permissions. – alfredocambera Sep 4 '14 at 14:57

I was having this same issue for one particular user on my domain and in addition to correctly setting the "Send-As" permission under the Security tab of the user mailbox in question, you must also ensure that the user who will be sending as the mailbox be added to the mailbox's Mailbox Rights.

To clarify:

1) Open the mailbox in question 2) Click on the Exchange Advanced tab 3) Click on Mailbox Rights 4) Add the AD user who will be sending emails as this mailbox 5) Ensure Full Mailbox Access is selected for the user 6) Click Apply and OK 7) Test if you can now send-as from user's Outlook client after waiting for Exchange to apply the change

Hope this helps, Jason S.

share|improve this answer

Edit the AD user account of the 'send as' address. Under 'exchange general' and 'delivery options' populate the 'send on behalf' list with those you want.

share|improve this answer
Thanks but no effect. – John Gardeniers Nov 8 '10 at 20:57

Sending as a user is different from sending to a user (as you say their error is). They are separate permissions. On the Exchange General tab, open Delivery Restrictions. Under Message Restrictions, ensure that that the user with Send As rights isn't denied access to send to this mailbox.

Delivery Restrictions from Exchange General tab of an AD User

Also, has that user logged out of Windows since you'd applied permissions? Exchange can be finicky whether it follows the Windows/AD rule that rights are applied on login; for some things it will just check rights as needed.

share|improve this answer
All checked and correct. It's now early morning and the client machine has been off overnight, so that gives everything plenty of time to catch up or refresh. – John Gardeniers Nov 8 '10 at 21:00

If the user is choosing the from address from their nickname cache it will fail. We have found the user must choose the FROM from the GAL to send as.

share|improve this answer
As this is a new account it had to be looked up in the GAL. The only possible issue I can think of is that the email address had previously belonged to another users. With that in mind I tested on a freshly installed machine to eliminate any possible user settings or data. Same result. – John Gardeniers Nov 8 '10 at 21:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.