Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a number of windows servers, both win2003, win2003r2 and win2003r2 64 bit. After installing windows updates on the machines and rebooting terminal services give me an immediate "not connect" message. The servers are running fine and you can connect via the physical machine.

Once you reboot the box (with remote restart in some cases when it's not accessible) terminal services behaves itself and allows a connection.

Whilst it's not a show stopper it is rather annoying when you can't see your box. Anyone know why this is or what the cause is?

share|improve this question
    
What debugging step did you take ? Have you already checked the firewall, terminal services status ? –  Stephane Nov 8 '10 at 10:25

2 Answers 2

I had something like this about a year ago in my old job, although it seemed to "go away" after a couple of hours (rebooting the servers didn't solve it). It turned out that I was running an older version of the rdp client. The problem was resolved by upgrading to the latest rdp client.

share|improve this answer

I consider this a fault in 2003 these days because I never did find out the problem. Sometimes it gets stuck trying to restart, with services like RDP stopped, responding to ping and such but not actually succeeding to reboot and with no notable logs...

...I usually just shrug my shoulders, initiate a remote restart (remote shutdown always works when this happens) and go on my merry way and replace it with 2008 R2. Initiating a ping -t if possible against a 2003 before rebooting it remotely helps detect this state, as it never stops responding even for a second.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.