Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using rsync to backup my server to an offsite server. Due to diskspace on my backup server, I have created a couple of symlinks to put some of the data on a different drive. However, instead of copying through to that symlink location, rsync is deleting the symlink and replacing it with a real directory.

How can I get rysnc to copy through the symlink on the destination?

share|improve this question
    
Can you tell us exactly how you're invoking rsync? –  MadHatter Nov 8 '10 at 11:23

2 Answers 2

up vote 1 down vote accepted

I think you need to use the option --no-implied-dirs.

For more info, see man rsync.

Look at the paragraph that explains the usage of this option.

share|improve this answer

According to the manpage, the -l flag to rsync:

-l, --links                 copy symlinks as symlinks

should do what you want.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.