Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have to install the latest version of MySQL server community edition 5.1.51 (i think is the latest). I haven't installed any MySQL on this centos machine yet, but when I do a locate mysql - it shows me mysqldump, mysqlshow etc etc on this system.

Now I have downloaded the rpms required :

MySQL-client-community-5.1.51-1.rhel5.i386.rpm
MySQL-devel-community-5.1.51-1.rhel5.i386.rpm
MySQL-embedded-community-5.1.51-1.rhel5.i386.rpm
MySQL-server-community-5.1.51-1.rhel5.i386.rpm
MySQL-shared-community-5.1.51-1.rhel5.i386.rpm
MySQL-shared-compat-5.1.51-1.rhel5.i386.rpm
MySQL-test-community-5.1.51-1.rhel5.i386.rpm

When I try to (as root) do the following : root@localhost#rpm -ivh MySQL-client-community-5.1.51.rhel5.i386.rpm

I got a long list of errors saying that the old version conflicts with this one, so I tried to remove mysql (if any) via rpm -e mysql it then complained about some dependencies for e.g. dovecot.x.s.x. and lib.something.

I removed rpm -e dovecot
then rpm -e mysql and it finished without complaining

I then installed :
rpm -ivh MySQL-client-community-5.1.51-1.rhel5.i386.rpm
rpm -ivh MySQL-devel-community-5.1.51-1.rhel5.i386.rpm
rpm -ivh MySQL-server-community-5.1.51-1.rhel5.i386.rpm
`rpm -ivh MySQL-shared-compat-5.1.51-1.rhel5.i386.rpm

and when I tried to install :
rpm -ivh MySQL-shared-community-5.1.51-1.rhel5.i386.rpm I got the following error :
Preparing... ########################################### [100%] file /usr/lib/libmysqlclient.so.16.0.0 from install of MySQL-shared-community-5.1.51-1.rhel5.i386 conflicts with file from package MySQL-shared-compat-5.1.51-1. rhel5.i386 file /usr/lib/libmysqlclient_r.so.16.0.0 from install of MySQL-shared-community-5.1.51-1.rhel5.i386 conflicts with file from package MySQL-shared-compat-5.1.51- 1.rhel5.i386

I have checked that MySQL is running and I can login to MySQL Server fine, do you think I need anyother packages for MySQL to function properly, we will be testing a MySQL DB on this machine but on 5.1.51.

Any thoughts / suggestions would be helpful.
Kind Regards

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You're trying to install too much.

In particular, you only need either:

MySQL-shared-compat-5.1.51-1.rhel5.i386.rpm OR MySQL-shared-community-5.1.51-1.rhel5.i386.rpm

Those two are mutually exclusive. The former contains various versions of the mysql libraries for backwards compatibility with software that's linked to those specific library versions. Pick MySQL-shared-compat-5.1.51-1.rhel5.i386.rpm if you're in doubt.

In short. The 4 RPMs you installed is enough for a fully functioning MySQL server. All is good.

share|improve this answer

My first thought was yum groupinstall mysql and Google search results suggest this is possible - is the latest version not available at the repositories?


EDIT

See also http://stackoverflow.com/questions/121502/installing-a-specific-package-version-with-yum

share|improve this answer
    
thanks for the prompt response - no i did a yum install on another box and it was 5.0.x.x something - so not the latest or it was 5.1.41 (not sure now - would have to check) - there shouldn't be no harm in installing via rpm -ivh ? –  rihatum Nov 8 '10 at 12:08
1  
So far as I know, the only problems with installing from RPMs are the ones you experienced - that you have to sort out the dependency issues yourself. Also that maybe yum no longer knows what software you have on your machine - which may have consequences for later use of yum. –  RedGrittyBrick Nov 8 '10 at 12:13
    
I have installed it already on this centos vm and just did a yum update, haven't faced any issue yet - so hope it stays like that :-) This would just be a basic CentOS MySQL DB VM and nothing else - so I guess it should be safe (not in production - just testing). –  rihatum Nov 8 '10 at 12:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.