Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting this event in my Application event log:

Event Type: Error
Event Source: Office SharePoint Server
Event Category: Office Server General 
Event ID: 7888
Date:  11/8/2010
Time:  11:15:36 AM
User:  N/A
Computer: ENTERPRISE
Description:
A runtime exception was detected. Details follow. 
Message: Windows NT user or group 'domain.com\admin' not found. Check the name again.

Techinal Details:
System.Data.SqlClient.SqlException: Windows NT user or group 'domain.com\admin' not found. Check the name again.
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
   at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
   at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
   at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)
   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)
   at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
   at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
   at Microsoft.Office.Server.Data.SqlSession.ExecuteNonQuery(SqlCommand command)
   at Microsoft.Office.Server.Data.SqlServerManager.GrantLogin(String user)
   at Microsoft.Office.Server.Administration.SharedResourceProvider.SynchronizeConfigurationDatabaseAccess(SharedComponentSecurity security)
   at Microsoft.Office.Server.Administration.SharedResourceProvider.SynchronizeAccessControl(SharedComponentSecurity sharedApplicationSecurity)
   at Microsoft.Office.Server.Administration.SharedResourceProvider.Microsoft.Office.Server.Administration.ISharedComponent.Synchronize()

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

I am convinced that it is because I installed and configured Sharepoint with a domain.com\admin account and not the netbios version, domain_com\admin. I have encountered this with other parts of sharepoint.

My question is: Does anyone know how to figure out what/where to change that account so that the error will go away. I have tried to add the account domain.com\admin to the sql server but since the account domain_com\admin is already there it won't let me. (It is the same account).

The site seems to work fine, other than filling up the event log.

I have searched the world over and found nothing.

I am having some issues with IIS where I need to do a reset. This is caused by the Sharepoint Timer service and I think if I can fix this issue it might fix the timer issue.

Thanks.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Can you login to the server or sharepoint with the given username?

First off, if you only used domain.com/admin as the installation user and nothing else, I don't think that is the cause of the problem.

Then take a look for Failure Audit entries on your sharepoint server and your domain controller to see if there is an obvious reason for the "user not found" error.

If that doesn't lead anywhere, take a look at all your Sharepoint service accounts, as these are the accounts that will be logging in here and there for Sharepoint. Given the "general" nature of the error, it seems likely to be the Central Admin app pool account, but it could be a Shared Service Provider pool account, or even a web application. Oh man - Sharepoint can have a lot of different accounts - it's a nightmare to keep track, even if only one of you set this up!

You should check each application pool's identity tab in IIS for your Sharepoint server, and note down which pool uses which account. Also check the account used by SQL server, and any other accounts you may have used for crawling etc.

Once you have this list, you can follow Microsoft's procedure for changing service accounts. If all your services/functions use the same account, you could try changing them to see if that fixes it.

If worst comes to the worst and things aren't working, as long as you have your config and content databases intact, you can blow away the Sharepoint server, and start again with your accounts. If you do this, I recommend using different accounts for each function as suggested by Microsoft. It may seem like overkill, but if nothing else makes the errors a lot easier to deal with!

share|improve this answer
    
I have gotten the error to go away by changing the Sharepoint Timer Service account. It really means that the first account doesn't have the right permissions to the database. I haven't had time to fix it properly or to go through your steps, I will just can't yet. I'll post an answer as soon as I have had a chance to follow through. I am using different accounts for the different aspects of sharepoint. Thanks for your help. –  Sylaei Nov 11 '10 at 22:32
1  
I was able to give the original account permissions to the database and that solved the issue. What I found was that the error did not actually contain the account I had to give permissions to, but it contained an account that already had permission. Thanks for the help. –  Sylaei Nov 12 '10 at 22:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.