Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I changed my sources.list to:

deb http://old-releases.ubuntu.com/ubuntu/ intrepid main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ intrepid-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ intrepid-security main restricted universe multiverse

I tried installing sudo apt-get install update-manager-core but i get this error:

1 upgraded, 3 newly installed, 0 to remove and 40 not upgraded.
Need to get 2506kB/2555kB of archives.
After this operation, 4346kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Err http://old-releases.ubuntu.com intrepid-updates/main update-manager-core 1:0.93.34
  404 Not Found
Err http://old-releases.ubuntu.com intrepid-security/main dpkg 1.14.20ubuntu6.3
  404 Not Found
Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.14.20ubuntu6.3_amd64.deb  404 Not Found
Failed to fetch http://old-releases.ubuntu.com/ubuntu/pool/main/u/update-manager/update-manager-core_0.93.34_amd64.deb  404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Running apt-get update or --fix-missing returns the same errors.

How can I successfully upgrade from Intrepid Ibex to Jaunty 9.04?

share|improve this question
    
Did you try sudo apt-get update before your install command? –  Janne Pikkarainen Nov 9 '10 at 10:24

2 Answers 2

A quick scan over the contents of the repository shows that they appear to have changed the architecture from amd64 to ia64 for that release, don't ask me why.

You should be able to solve this problem by adding a file 01internal (or any other name you like) to /etc/apt/apt.conf.d/. The file should look like this:

APT::Architecture "ia64";

Then re-run apt-get update and hopefully it should start working.

Also, it's good practice to do a apt-get dist-upgrade when moving between releases. It's possible they worked this wrinkle out so that a dist-upgrade will go smoothly without the above magic, but I don't have the appropriate machines to test that theory on.

share|improve this answer
    
Unfortunately adding that line gives: E: Internal Error, Could not perform immediate configuration (2) on libunwind7 –  tommy chheng Nov 9 '10 at 15:26
2  
ia64 is for itanium and not for amd64 - it's a different architecture –  Jure1873 Oct 17 '11 at 15:48
    
Quintessential example of "knowing just enough to be dangerous." –  Skyhawk Dec 17 '11 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.