Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

we are having an issue with our HaProxy w/ IIS and ColdFusion setup. The setup works fine however pages gradually degrade in response time going from 2-3 seconds to 3-4 mins. The odd part is that a restart of IIS fixes this issue and the pages fly again. Anybody seen this behaviour before? Below is our config file on HaProxy.

log local0
log local1 notice
#log loghost local0 info
maxconn 4096
user haproxy
group haproxy

log global
mode http
option httplog
option dontlognull
retries 3
maxconn 2000
contimeout 5000
clitimeout 50000
srvtimeout 50000
stats uri /monitor
listen webfarm
bind :80,:443
mode tcp
balance source
#cookie SERVERID insert indirect
#option httpclose
#option forwardfor
#option httpchk HEAD /check.txt HTTP/1.0
server webA
server webB
share|improve this question

1 Answer 1

It's hard to tell since your health checks are disabled. Maybe one of your IIS is hung and haproxy has to retry multiple times on it before finally connecting to the other one.

What I'd also suspect is that you may have some connection leaking on your IIS, which would be noticed by a vast number of CLOSE_WAIT connections on the server. If so, it could be a bug in the application which does not correctly handle passive connection closing (this is common to see newbie developers believe they have nothing to do when a connection closes).

share|improve this answer
It's a pleasure to have you here! Welcome to Serverfault. :-) –  Jesper Mortensen Nov 10 '10 at 7:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.