Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For starters - I'm not an admin, I'm a programmer, so please give me basics when you feel it's necessary.

The background: At uni we decided with some friends and a PhD to write an application to aid teachers in their work. We have an VM with Windows Server 2008, I have administrative rights on it, and I've installed TFS 2010 and everything else we need (SQL Server 2008 + some tools). VS2010 connects flawlessly to the TFS server when we're on the local network, but does not when we're in home. I'm familiar with the use of VPN (which would help in our case), but I've never configured it. I have forced the domain administrator to let me use his account to set up the Windows Server VPN (the built-in one, by adding a role and then configuring everything in server manager) on the machine.

The problem: I have no clue how to connect to the virtual network from our private machines. We all have Windows 7 Pro or Ult. Is there any built-in VPN client? If not, can we use something like OpenVPN (I use it at work), or does it require server to be installed on the VM, and a separate configuration?

Too long : How to connect from a Win7Ult machine outside a LAN to a VPN configured on Windows Server 2008 machine (the built-in VPN, not any third party VPN server)?

Please don't send me to the network admin, he doesn't know a thing - that's why I had to configure the VPN.

I'm not good at that configuring stuff nor do I enjoy it, so if you could help me I would appreciate it greatly ;)

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Is there any built-in VPN client?

Yes. Create new network connection, same place you can see the network cards.

Howto is... ...here:

http://www.windows7hacker.com/index.php/2009/08/how-to-set-up-a-vpn-connection-in-windows-7/

share|improve this answer
    
Thank you very much :) I think it works, i.e. the client works, but something between my machine and the VM blocks the connection (error 800). I've searched the error and now I have to fight with the admin to open tcp:1723 and enable protocol 47 (am I right? :P ) –  CodeMonkey Nov 9 '10 at 19:19
    
Yes. You need TCP 1723 (control channel) and IP subprotocol (GRE).... OR you use SSL or another protocol instead of PPTP... if it is configured on the server. –  TomTom Nov 9 '10 at 21:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.