Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a virtual machine running Windows Server 2008 (client) on a Windows Server 2003 (host). I'm running Virtual Server 2005 R2 with SP 1. I can not install Virtual Machine Additions on the client. I've tried running via the ISO as well as copying the MSI to the client machine, but every installation attempt ends the same:

Setup was interrupted before Virtual Machine Additions could be completely installed.

I've tried uninstalling previous versions of VMA but the uninstall never works either.

I've tried altering safe mode to allow for uninstalls and that fails, I've tried safe mode installation and that fails. I'm running as administrator.

share|improve this question

Did you check the installer log file? Start the installation using:

msiexec.exe /i yoursetupfile.msi /lvoicewarmupx logfile.txt

After installation, search the log file for errors and warnings. (Note: you obviously need write permissions for the path to log file)


I presume you already googled for 1603, but here are some notes (found on MSDN) anyway:

You may receive this error message if any one of the following conditions is true:

  • The folder that you are trying to install the Windows Installer package to is encrypted.
  • The drive that contains the folder that you are trying to install the Windows Installer package to is accessed as a substitute drive.
  • The SYSTEM account does not have full control permissions on the folder that you are trying to install the Windows Installer package to. You notice the error message because the Windows Installer service uses the SYSTEM account to install software.

Some additional information can be found on InstallShield site (although your installer is not InstallShield based):

  • Short file name creation is disabled on the target machine.
  • An InstallScript custom action is prototyped incorrectly.
  • Some file is locked and cannot be overwritten.
  • The Microsoft Windows Installer service is not installed correctly.
  • The Windows Temp folders are full.
  • File and Printer sharing is not enabled or was not installed when installing Windows.
share|improve this answer
The intaller log records an error 1603, but that doesn't help much. – user59724 Nov 10 '10 at 15:03
all uninstall attempts return error 1603 as well. – user59724 Nov 10 '10 at 16:07
Yeah, no encryption and I can't imagine any file locks. I think it has something to do with an older version of VMA that has lingering elements on the system. I'm now uninstalling Virtual Server R2 on the host machine, reinstalling Virtual Server R1 reinstalling the old version of VMA on the client, uninstalling that, then uninstalling Server R1, installing R2 and trying to reinstall VMA with R2 SP1. Oy. – user59724 Nov 11 '10 at 19:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.