Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Please let me clear steps to install oracle 11g from local linux(or windows) machine to remote server( OS : Ubuntu).

When I try to run the runInstaller command,its not working from windows local machine.

share|improve this question




Begin by making sure that your system is up to date with all its packages:

SSH into the remove system (via putty or the client of your choosing)

then run

# apt-get update
# apt-get dist-upgrade 
# reboot

Once the system has rebooted - you should be in working shape and up to date.

There are a number of packages required to install Oracle -so reconnect via ssh and then issue the following command

#apt-get install build-essential libaio1 gawk ksh libmotif3 alien libtool lsb-rpm

Next - you will need to make a few changes to the system configuration:

# cd 
# pwd 

Add a few groups here: oinstall, dba and nobody

# addgroup oinstall 
# addgroup dba
# addgroup nobody
usermod -g nobody nobody

Add the oracle user

# useradd -g oinstall -G dba -p password -d /home/oracle -s /bin/bash oracle   
# passwd oracle 

Now give Oracle its own home directory

# mkdir /home/oracle 
# chown -R oracle:dba /home/oracle 

Next - create the symbolic links

# ln -s /usr/bin/awk /bin/awk   
# ln -s /usr/bin/rpm /bin/rpm   
# ln -s /usr/bin/basename /bin/basename   
# mkdir /etc/rc.d   
# for i in 0 1 2 3 4 5 6 S ; do ln -s /etc/rc$i.d /etc/rc.d/rc$i.d ; done

Next - Create the ORACLE_BASE

# mkdir -p /u01/app/oracle   
# chown -R oracle:dba /u01

There are a number of parameters that need to be changed in the system configuration to ensure the system is ready to run the application -

First - change the size of shared memory in the /etc/sysctl.conf file

fs.file-max = 65535   
kernel.shmall = 2097152   
kernel.shmmax = 2147483648   
kernel.shmmni = 4096   
kernel.sem = 250 32000 100 128   
net.ipv4.ip_local_port_range = 1024 65535   
net.core.rmem_default = 1048576   
net.core.rmem_max = 1048576   
net.core.wmem_default = 262144   
net.core.wmem_max = 262144

Integrate the following into the /etc/security/limits.confce file:

oracle soft nproc 2047   
oracle hard nproc 16383   
oracle soft nofile 1023   
oracle hard nofile 65535 

it will add the following to /etc/pam.d/login to validate parameters /etc/security/limits.conf:

session required /lib/security/   
session required


Now simply log into the system as the Oracle user via the login/password created in the previous steps above:

Now download and launch the Oracle runInstaller and follow the prompts

Once it is completed - it should make some changes to your /etc/profile - no worries as this should be done automagically.

Finally - add the following variables to the /etc/profile:

export ORACLE_BASE=/u01/app/oracle   
export ORACLE_HOME=/u01/app/oracle/product/11.X.Y/db_home1   
export ORACLE_OWNR=oracle   

You should now be complete :-)

If you are unsure how to use SSH -I would suggest contacting a SysADMIN to help. however - if you do a quick google search for putty.exe - you can download it and then run to begin.

share|improve this answer
Glenn,I don't have apt-get(apt packages),dpkg,startkde,gnome-session command. – sameer Nov 10 '10 at 12:08
So,I can't do any installation without these commands, and I tried installing oracle from my local windows machine at remote server.For that I needed VNC server for OUI ,I installed VNC server at my remote server,But I try to run that vnc server,it doesn;t work since it says startkde(or gnome-session),twm commands not found. – sameer Nov 10 '10 at 12:14
When I tried runnign runInstaller using ssh from my other local linux machine at remote ubunutu server,then I need X11 forwarding for that,I did that , tried again,it says,this error...... X connection to hostname:10.0 broken (explicit kill or server shutdown).Please help me,Its very urgent. – sameer Nov 10 '10 at 12:17
Sameer I tested this locally - you may want to make sure you are using the correct repositories to install from. – Glenn Kelley Nov 10 '10 at 15:00
No,I have downloaded packages under u01/app/oracle/database ,there is an runInstaller,which I tried running.Please suggest some solution. – sameer Nov 11 '10 at 13:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.