Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is becoming rather frustrating. I'm trying to set up a VPN on a pix 501 using Cisco client v5. The connection is established fine but I cannot see the clients on the inside interface of the pix at all. Here's the configuration.

Note: ips for VPN clients are in the range of 192.168.20.x, those for LAN clients are in the range of 192.168.10.x. Also, external_ip = IP assigned by ISP via DHCP. One thing I have noticed once the cisco client is connected is that an ipconfig /all shows that the default gateway for the Cisco adapter is assigned to be 192.168.20.1.

Any help/direction would be really appreciated. Thank you.

----start config--------------

interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ****** encrypted
passwd ***** encrypted
hostname pix
domain-name domain.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 deny tcp any any eq 6669 
access-list 101 deny tcp any any eq 2222 
access-list 101 deny tcp any any eq 7000 
access-list 101 deny tcp any any eq 16959 
access-list 101 deny tcp any any eq 27374 
access-list 101 deny tcp any any eq 6711 
access-list 101 deny tcp any any eq 6712 
access-list 101 deny tcp any any eq 6776 
access-list 101 deny tcp any any eq 16660 
access-list 101 deny tcp any any eq 65000 
access-list 101 deny tcp any any eq 27665 
access-list 101 deny udp any any eq 31335 
access-list 101 deny udp any any eq 27444 
access-list 101 deny ip 192.168.0.0 255.255.0.0 any 
access-list 101 deny ip 172.16.0.0 255.240.0.0 any 
access-list 101 deny ip 10.0.0.0 255.0.0.0 any 
access-list 101 deny ip 127.0.0.0 255.0.0.0 any 
access-list 101 deny ip any any 
access-list 101 permit tcp any any eq www 
access-list 101 permit tcp any host external_ip eq pptp 
access-list 101 permit gre any host external_ip 
access-list allow_ping_to_out permit icmp any any echo-reply 
access-list allow_ping_to_out permit icmp any any source-quench 
access-list allow_ping_to_out permit icmp any any unreachable 
access-list allow_ping_to_out permit icmp any any time-exceeded 
access-list NONAT permit ip 192.168.10.0 255.255.255.0 192.168.20.0 255.255.255.0 
pager lines 150
logging on
logging timestamp
logging trap informational
logging host inside 192.168.10.9
icmp deny any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.10.1 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 192.168.20.50-192.168.20.65
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group allow_ping_to_out in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server TACACS+ max-failed-attempts 3 
aaa-server TACACS+ deadtime 10 
aaa-server RADIUS protocol radius 
aaa-server RADIUS max-failed-attempts 3 
aaa-server RADIUS deadtime 10 
aaa-server LOCAL protocol local 
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac 
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool vpnpool
vpngroup vpn3000 dns-server 192.168.10.1 68.87.69.150
vpngroup vpn3000 wins-server 192.168.10.1 68.87.69.150
vpngroup vpn3000 default-domain domain.local
vpngroup vpn3000 split-tunnel 101
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 30
console timeout 0
dhcpd address 192.168.10.5-192.168.10.29 inside
dhcpd dns dns_ip_1 dns_ip_2
dhcpd lease 648000
dhcpd ping_timeout 750
dhcpd enable inside

-----stop config------
share|improve this question
    
Can't really say what's the problem, but why don't you use 10.10.10.0 for the VPN instead of 192.168.20.0 ?. It will be easier to find the problem in that case. (Otherwise you must be very careful with routing / configuration / anything ) –  Nikolaidis Fotis Nov 10 '10 at 10:44
    
That's a good tip, thanks. –  Bourne Nov 10 '10 at 16:09

1 Answer 1

I need some clarification here to be sure, do you mean LAN client side is inaccessable or LAN vpn side is?

Let's assume for the moment you mean the LAN client side, i.e. you are working from home vpn'ing into the office and need to be able to access that home network printer.

Unfortunatly I only have an ASA here to go on, what you are looking for is called "Split tunneling" this allows VPN connection whilst simultaneously allowing LAN access, and internet access over the local connection instead of the VPN.

A caveat of this is if you require the use of internal DNS to resolve Office LAN side hosts, split tunneling will useually differ DNS to client LAN side servers.

Ref for ASA/PIX: http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a0080702999.shtml

share|improve this answer
    
No, I actually mean LAN on the VPN side. I have been able to get split tunneling to work so that's not a problem but no matter what I do I cannot access any machines on the inside interface when VPNing in from outside. My situation is reversed from what you described. I'm at work, trying to VPN to my home network behind the pix. As I mentioned in the original post, the gateway for the cisco client at work is grabbing 192.168.20.1. Shouldn't it be 192.168.10.1 which is the ip for the inside interface of pix? –  Bourne Nov 10 '10 at 16:16
    
Is VPN traffic considered to be ending on the inside interface by default or do I need to add a static route to do that? Also, I have a statement right now that explicitly permits traffic from VPN Lan to the IP pool assigned by VPN. Do I need one that does the reverse as well? I am referring to this one "access-list NONAT permit ip 192.168.10.0 255.255.255.0 192.168.20.0 255.255.255.0" How does the VPN traffic flow in Cisco devices? –  Bourne Nov 10 '10 at 16:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.