Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hello I was able to install MS-DOS 6.0 on the ESXi server and was able to install 3.11 windows, but when I try to start windows for the first time the mouse and keyboard dont work. I can see the cursor blinking on the password prompt so it doesnt look like it froze but I cant do anything. Any thoughts ? Thanks

share|improve this question
3  
+1 for stupidity! Why ever would you do that? I salute your foolishness! –  geoffc Jun 4 '09 at 20:37
1  
Same reason some people like to get their system to dual boot 20 different operating systems :) –  Kevin Kuphal Jun 4 '09 at 20:42
2  
Not Stupidity, we have a need to Windows 3.11 for workgroups, its a MS supported OS, and still hasnt reach EOL. –  user8210 Jun 4 '09 at 20:58
2  
geoffc: Having a Windows 1.03 virtual machine, I hereby punch you in the face. –  grawity Jun 4 '09 at 21:22
1  
@user8210 You may indeed have a need for it, but I can assure you that it is not a Microsoft Supported OS. Support has long since expired... And if you have a legitimate need for Windows 3.11, you're probably (doing whatever it is that you're doing) wrong. –  gWaldo Oct 12 '10 at 18:34

5 Answers 5

Windows 3.1x is supported under ESX 4.0

http://pubs.vmware.com/guestnotes/wwhelp/wwhimpl/common/html/wwhelp.htm?context=guestnotes&file=guestos_doswin.html

Also see the known issues section

share|improve this answer
    
Yes I saw that, but I need it on ESXi which is under 3.5 structure. –  user8210 Jun 4 '09 at 20:53
3  
Just because you need it doesn't make it possible. It's possible the virtual hardware support isn't present in 3.5 to make it work. –  Kevin Kuphal Jun 4 '09 at 21:46

I tried a WFW 3.11 VM I had created under Vmware workstation 4.x on an ESX 3.5i server and it worked for me. I have no idea why it wouldn't be working for you. Perhaps the virtual hardware that is selected for a new VM is different then what I got from the imported VM.

You might want to try creating a VM in an older version Vmware and then importing it.

share|improve this answer
    
I`m going to try that right now. I have VMworkstation 6.5 where it works fine, I did import it from there but it was created with 5 settings let me try. –  user8210 Jun 5 '09 at 13:23
    
Nope same thing, mouse and keyboard are not working.... Can you run thru your settings please? I created in VMware workstation 6.5 with 4 settings, selected windows 3.1 as the OS and all the other defaults. Then used VMware Vcenter standalone converter and took all the defaults. –  user8210 Jun 5 '09 at 13:35

Perhaps ESX only emulates USB keyboards and mice? just an idea - not sure but it would explain it.

share|improve this answer
1  
Yeah, that would be my first theory as well. No USB support there. –  squillman Jun 4 '09 at 20:02
1  
I thought of it, but it looks like its PS/2 as in windows XP on that same box in device manager it shows PS/2 –  user8210 Jun 4 '09 at 20:54
1  
Nope, ESX emulates PS/2 mouse and keyboard. –  kbyrd Jun 4 '09 at 21:17
    
cheers chaps, thanks for clarifying –  Chopper3 Jun 4 '09 at 21:44

When you're in the MS-DOS prompt, switch to the \windows folder and run SETUP. Check to see if the installtion options (particularly the keyboard) match your real-life setup.

(Man this is bringing back memories of the old days)

share|improve this answer
    
Did that some thing. –  user8210 Jun 5 '09 at 14:28

Just stay in MSDOS and run DoomSweeper and you will be fine. You don't need any Windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.