Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For connecting to a Windows 7 virtual machine on a LAN, what would be the ideal settings to specify when using rdesktop in linux so that it feels as close as possible to using a regular Windows 7 machine? And is there anything I should configure on the Windows VM?

Thank you! :D

share|improve this question
add comment

3 Answers

It takes some tweaking. The command-line I'm using in a shortcut for my VMWare VM Win7 admin station is :

/usr/local/bin/rdesktop -d $domain -u $username -g 1270x972 -z -r sound:local -P -x l $hostname

Works pretty solidly. I had to compile a newer rdesktop since the one that comes with my distro is a bit old. Pretty snappy. Still not as snappy as talking to XP, but markedly better than it is with no special options.

share|improve this answer
add comment

After some grief, I've switched to using xfreerdp - it lacks a lot of the issues rdesktop has with the more modern windows builds, and feels a bit faster (might be wrong here)

share|improve this answer
add comment

I came upon this after investigating various sources. Here's what I use:

rdesktop -u USERNAME -d DOMAINNAME -p - -g 1680x1050 -a 24 -z -x 0x80 -D -r clipboard:PRIMARYCLIPBOARD -r sound:remote MACHINENAME

-x 0x80 will allow clear type tuning to work (see here) assuming you have Windows XP SP3, Vista or 7 as the server.

If you get a warning saying 24 bit color depth is not allowed, you will need to use the group policy edtor on the server machine to change the Administrative Templates -> Windows Components -> Terminal Services -> "Limit maximum color depth" setting. (see here)

I forgot to mention, on Windows XP, you will also need to add a DWORD value to your registry: AllowFontAntiAlias with value 1 at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp (source) and restart your machine.

The above also removed windows manager decorations and passes all keys (Ctrl+Alt+Del etc.) to the Windows machine. I have the resolution explicitly specified in place of using full screen mode on rdesktop to prevent it from taking over both monitors.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.