Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Exim4 on Ubuntu 10.04, using it for sending emails out from various programs on our LAN. I have program that sends out approx. 60 emails once a month and Exim's default setting of only sending out 10 emails prior to the remaining being queued is causing an inconvenience in this case. In the Exim log files, I receive a notification of: "no immediate delivery: more than 10 messages received in one connection". I have scoured the internet but have not found a fix. I have added this line: smtp_accept_queue_per_connection=100 to /etc/exim4/update-exim4.conf.conf and restarted Exim but this does nothing. I have also tried smtp_accept_queue_per_connection=0 but this does not accomplish anything either. Can anyone shed some light on what setting needs to be changed to allow more than 10 emails to be sent at one time? Thanks.

share|improve this question

1 Answer 1

I had that problem too but on debian and i think you just edited the wrong file.

its probably one of those two: /etc/exim4/exim4.conf.template - if you use single file config /etc/exim4/conf.d/main/02_exim4-config_options - for split file config

and you need to rebuild the configuration, on debian "/etc/init.d/exim4 reload" does that for you but better check the manpages of your os (try: man update-exim4.conf)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.