Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to build a linux box that will run without a monitor or keyboard, runs Ubuntu server, will go into suspend after a certain amount of time and is able to be woken up through network communication. Most of it is already in working order, except for the Wake-on-LAN part.

By the way, my computer is very old (bought it in 2002).

Some relevant info (I hope):

NIC: RTL-8139/8139C/8139C+ (Realtek).

Motherboard: SiS-645 (vendor: Gigabyte Technology Co., Ltd.)

Award BIOS capabilities (according to lshw):

isa pci pnp apm upgrade shadowing cdboot bootselect socketedrom edd int13floppy360 int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb agp ls120boot zipboot netboot

Off course I activated the WakeOnRing/WakeOnLan (as it's called on my Award BIOS) setting, as well as some setting called PME or something.

output from $ sudo ethtool eth0:

Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
    Link partner advertised pause frame use: No
    Link partner advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 32
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: d
    Current message level: 0x00000007 (7)
    Link detected: yes

So obviously it's not working because it's on the 'd' setting. So I run the command:

$ sudo ethtool -s eth0 wol g

But with NO effect. I've tried all combinations..

-- EDIT --

Just to be clear: when I run ethtool eth0 after this last command again, the output still says 'd' at "Wake-on". Disabling the WakeOnLan function in the BIOS also has no effect on the situation whatsoever by the way, if that's enlightening in any way.

-- EDIT --

I've tried lots of time, to just wake it up using a magic packet, but (as can be expected with ethtool's output) it's not working.

Here's the eth0-part of the output from $ sudo lshw:

id:           network:1
description:  Ethernet interface
product:      RTL-8139/8139C/8139C+
vendor:       Realtek Semiconductor Co., Ltd.
physical id:  c
bus info:     pci@0000:00:0c.0
logical name: eth0
version:      10
serial:       00:11:22:33:44:55
size:         100MB/s
capacity:     100MB/s
width:        32 bits
clock:        33MHz
capabilities: bus_master ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd
    autonegotiation = on
    broadcast       = yes
    driver          = 8139too
    driverversion   = 0.9.28
    duplex          = full
    ip              =
    latency         = 32
    link            = yes
    maxlatency      = 64
    mingnt          = 32
    multicast       = yes
    port            = MII
    speed           = 100MB/s
    resources:      irq : 11
                    ioport : e400(size=256)
                    memory : ee003000-ee0030ff

I do not have a cable running from my network card to my motherboard and I don't see any 3-pin connector. I could be wrong though, if anyone with the same card says different I'll be sure to check again.

So, if ANYONE knows how I can solve this problem, or convince me that without a different network card, motherboard or computer I'm pretty much screwed, please tell me!

Thanks in advance.

share|improve this question
Never used WOL myself so I can't help much, but did you look to see if the kernel logged an explanation of why it can't enable WOL? (check dmesg or /var/log/kern.log afterwards) – DerfK Nov 11 '10 at 1:31
SiS 645 is the chipset, not the motherboard. Any chance you can figure out the motherboard model, or give some more specs on the rest of the computer (CPU socket/speed, RAM slots/speed, number of IDE channels, physical descriptors of the board)? – Theo Nov 11 '10 at 2:56
The 3-pin cord is the key (on older computers)--it powers the card so that it can receive the magic packet. – Theo Nov 11 '10 at 3:00
I just examined the card again, it says RTL8139B on the chip. Wikipedia's article on this chipset has a table of versions and their respective features, the "B" version does not list "Wake on LAN", while the others do. I guess I'm out of luck. Thanks for your replies, you were right Theo. BUT I also have an "Alfa USB" wireless network adapter with a RTL8187 chipset. I don't like to use wireless for this machine, but maybe as temporary solution. Is it possible to use a USB dongle as a wake-up device? I didn't find anything pertaining to my RTL8139 card btw in dmesg or /var/log/kern.log. – pancake Nov 11 '10 at 15:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.