Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a nice Talkswitch voip system. Per the Talkswitch specs, ports 5060 / UDP, 6000 - 6006 / UDP, 69 / UDP, 8484 / TCP, 9393 / TCP are all mapped to the Talkswitch unit. It has built in voip router connectivty tests which it passes.

At the remote location, I have a Talkswitch voip phone, model TS-350i behind a linksys nat firewall. I configured the Talkswitch pbx with the phone's mac address and the phone with the public ip address of the switch.

The phone does some amount of comms with the switch and manages to learn its ext number and station name. But it doesn't fully register with the switch and calls don't work.

Questions: 1) The remote office is served by Time Warner roadrunner service. Do they block voip ports? What is the recommended way to test?

2) The Talkswitch support tells me that the phone goes through a nat firewall with no adjustments needed on the firewall. Does that make sense? I thought I'd need to open up ports on the firewall, no?

Thanks.

share|improve this question
add comment

1 Answer 1

Road Runner tends to block high ports. However, I was able to get my remote phone working by using Port Address Translating (similar to NAT, and frankly it's the same thing)...

On your remote network in your router settings, map each one of the ports Talkswitch specifies...

ports 5060 / UDP, 6000 - 6006 / UDP, 69 / UDP, 8484 / TCP, 9393 / TCP

...to an unused outbound port below 1024 (UDP 69 does not need translating), then on your company router map those incoming ports back to the Talkswitch device on the correct port.

The phone system has no problem with this because to it, it's sending and receiving on the right port.

Horrible text graph below. If it doesn't make sense let me know and I'll do a graphical in the morning.

Remote Phone <> (Port 5060 UDP) <> Remote Router <> Internet (Port 1011 UDP) <> Local Router <> (Port 5060 UDP) <> TalkSwitch box.
share|improve this answer
    
Thanks. Turns out the problem was some misconfig on my side. The phone is now working well. But I still don't know how it's getting through the nat at the remote location. That'd be useful to know. –  LarryK Nov 11 '10 at 4:41
    
The remote phone is designed to work behind a router with NAT. Typically it's preconfigured with the public IP of your company network, and it just sends its packets to that IP, and the home router automatically makes that connection for you. –  Theo Nov 11 '10 at 12:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.