Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Linux Fedora server running Bind 9.5.0 and DHCP 3.0.6. Bind is configured to allow updates (I'm only showing part of the config, but the reverse part is there too):

zone "myhome.org" IN {
    type master;
    file "named.myhome.org";
    allow-update { key "myrndckey"; };
    notify yes;
};

and DHCP is configured to provide updates to Bind:

zone myhome.org. {
    primary    192.169.1.1;
    key        "myrndckey";
}

When a Windows DHCP client connects to my network, I can see it by nslookup (dig, etc). However, when a Linux DHCP client connects, while it successfully gets a DHCP lease, its name and address do not appear in DNS.

Does anyone have any ideas what could be missing from my configuration that would cuase this? Could it be something missing on my Linux client configuration?

share|improve this question
add comment

4 Answers

Your Linux client configuration needs to be updated. Add the following line

send host-name "hostname";

to your equivalent of /etc/dhcp3/dhclient.conf. (That's where Debian stores the DHCP client configuration file.) This will tell the DHCP server the hostname of your Linux client. The DHCP server should now configure the appropriate DNS entries for your Linux client.

share|improve this answer
add comment

The windows clients are probably updating the DNS server themselves, based on the key information supplied by the DHCP server.

share|improve this answer
add comment

maybe you need to add something like this to your linux dhcp server? (/etc/dhcpd.conf)

ddns-domainname         "example.com.";
ddns-rev-domainname     "in-addr.arpa.";
ddns-update-style       interim;
ddns-updates            on;
share|improve this answer
add comment

This could be b/c your Fedora DHCP client implementation does not have all the settings. Check your /etc/sysconfig/network-scripts/ifcfg-ethX where X could be 0 or 1 or other...depending on what your primary network card is, and how many you have etc.

I believe you need to have: DHCP_HOSTNAME=your_hostname

For it to pass it's hostname on to the DHCP server, so it can then pass it on to DNS server via DDNS. Take a network packet capture of the DHCP transactions from your Linux client to the Server, and make sure you see the appropriate option with the hostname being passed. I think it's option 12.

Good luck.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.