Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I ping a dedicated ip on my server I get the following:

ping XXX.XXX.95.175
PING XXX.XXX.95.175 (109.72.95.175): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3

If I ping the main ip on my server instead it works:

ping XXX.XXX.95.174
PING XXX.XXX.95.174 (109.72.95.174): 56 data bytes
64 bytes from XXX.XXX.95.174: icmp_seq=0 ttl=57 time=15.813 ms
64 bytes from XXX.XXX.95.174: icmp_seq=1 ttl=57 time=15.183 ms
64 bytes from XXX.XXX.95.174: icmp_seq=2 ttl=57 time=36.285 ms

So I was now wondering: is it an issue in my webserver configuration file or should I contact my hosting provider ?

They already told me that it is my webserver configuration issue.. but I'm not sure about it.. could you give me some tip please ?

Update

Should I just add this ?

iface eth0:1 inet static
address XXX.XXX.95.175
netmask 255.255.255.0
gateway XXX.XXX.95.174
share|improve this question
    
if your paying for support, use it! –  The Unix Janitor Nov 11 '10 at 10:39
    
I think your update is almost correct for Debian (and possibly other distributions) except that I think you should use eth0:0 and the gateway should be the same as the gateway value for the main eth0. –  RedGrittyBrick Nov 11 '10 at 12:12
    
@RedGrittyBrick Ok cool (I'm on Ubuntu). I was actually wondering if this configuration could create issues to SSL certificate. I mean.. am I redirecting the traffic to my old ip ? Or am I effectively using the first ip ? I don't want to find out later that the SSL certificate doesn't work because of this. –  Patrick Nov 11 '10 at 12:14
    
No you are not really redirecting traffic to a different destination address, your single network interface will now accept packets with either destination address. I'm not sure how this affects your SSL certificates - aren't they tied to hostnames?. –  RedGrittyBrick Nov 11 '10 at 12:23
    
I've retagged your question with a 'Ubuntu' tag (it would have been helpful to know this earlier) –  RedGrittyBrick Nov 11 '10 at 12:30
add comment

2 Answers 2

up vote 1 down vote accepted

There is a potential problem of terminology. When people say "webserver" they might be referring to either

  • The application that listens for HTTP requests. e.g. Apache HTTPD server.
  • A computer whose primary purpose is to run such an application.

In the first sense

Ping failure is nothing to do with webserver configuration.

Ping normally uses the ICMP protocol.

Webservers use HTTP over TCP over IP protocols.

Generally

If you cannot ping an IP-address then you have a networking problem that might lie at the client end (the PC where you type the ping command), in the LAN (e.g. port failure on a switch) or in the server (misconfiguration or NIC failure).

On the computer that runs your webserver, check the configuration

  • Windows: ipconfig /all

  • Unix/Linux: ifconfig -a

Check that one of the interfaces has the address XXX.XXX.95.175 and is "Up".

Check that any firewall on the server is not blocking ping (e.g. blocking ICMP)


EDIT:

If the server has a single network interface (NIC), you can run two IP-addresses on a single card by using an IP alias. On Linux servers this can usually be accomplished using the ifconfig command and using a :0 suffix for the device:

  ifconfig eth0:0 192.168.5.12 netmask 255.255.255.0 up

You will also need to add this to a system startup script, or add equivalent details to config file. The location of the file depends on your OS & distribution - for example /etc/rc.d/rc.local - Read the documentation for your operating system (or tell us the response to uname -a).

For Ubuntu see this article

share|improve this answer
    
@RedGrittyBrick 1) Since I'm pinging successfully the first url, it is not possible the issue is with the client-side, right ? –  Patrick Nov 11 '10 at 11:02
    
2) I've executed ifconfig -a and I don't see any interface with ip XXX.XXX.95.175. I 've root access to unix. Can I fix it by myself and adding the missing interface, or should I call support ? –  Patrick Nov 11 '10 at 11:04
    
Why do you need two IP-addresses? If you paid the provider for two IP-addresses you should call support and find out why your server isn't configured for two IP-addresses. Partly this depends on what sort of arrangement you have with them (VPS, dedicated, ...) - this determines which of you is responsible for configuring the operating system. –  RedGrittyBrick Nov 11 '10 at 11:18
    
@RedGrittyBrick The ip is supposed to work I need to configure my network configuration. Could you tell me if the snippet I added to the question is ok ? –  Patrick Nov 11 '10 at 12:10
    
@Patrick, I don't have a Ubuntu server to hand at my current location, check the link in my answer above - If in doubt, try using one of the GUI tools mentioned in that article. –  RedGrittyBrick Nov 11 '10 at 12:26
show 1 more comment

Ubuntu uses the '/etc/network/interfaces' file to set permanent ip addresses. So if you would like multiple it would look something like the following:

# The primary network interface
auto eth0
iface eth0 inet static
    address 10.10.150.13
    netmask 255.255.255.0
    network 10.10.150.0
    broadcast 10.10.150.255
    gateway 10.10.150.254

auto eth0:1
iface eth0:1 inet static
    address 10.10.150.14
    netmask 255.255.255.0

Afterwards run 'ifup eth0:1' to enable it.

share|improve this answer
    
So, I even don't need the last line gateway XXX.XXX.150.13 in the second interface ? I want to setup a SSL certificate using the second ip, I will use your configuration if you confirm it is fine. –  Patrick Nov 11 '10 at 12:16
    
Nope, just like the above is sufficient. –  Mark Nov 11 '10 at 12:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.