Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

'exportfs -r' returns me this error when I'm trying to export /home/user/share (ext4):

exportfs: Warning: /home/user/share does not support NFS export.

/etc/exports:

/home/user/share 192.168.1.3 (rw,no_subtree_check)

The system is Ubuntu 10.04 with nfs-kernel-server package. Any ideas why this is happening? Is it because of ext4?

share|improve this question
    
This may be a related bug. bugs.debian.org/cgi-bin/bugreport.cgi?bug=602956 Have you considered using a user-space NFS server? –  Zoredache Jan 5 '11 at 3:35
    
Same problem on ubuntu 11.04. Can't export dir in encrypted home dir, but if i create a new dir e.g. /exports it works fine with nfs. –  user87939 Jul 17 '11 at 19:19

4 Answers 4

nfs-kernel-server cannot work with a FUSE folder like an encrypted ecryptfs home directory.

share|improve this answer
1  
Can you explain why that is so? Are there other nfs server packages that would work with FUSE? –  d_inevitable May 10 '13 at 6:50
    
An user-space NFS server like UNFS3 may works unfs3.sourceforge.net –  Giovanni Toraldo May 10 '13 at 8:05
    
I've tried to find a NFS4 version of that, with no success. Anyway, thanks for the info. –  d_inevitable May 11 '13 at 0:29
    
you should accept this reply as the anwser to your question. –  Giovanni Toraldo Nov 30 '13 at 8:34

Having a similar issue with 10.10. I believe it has something to do with having your export file system encrypted.

share|improve this answer

Had this problem due to a space in the path. Renaming the folder to remove all spaces resolved the issue for me.

share|improve this answer

After some time I think I have solution. Due to NFS doesn't work under encrypted directory and this is probably only your home folder, you must move your directory to unencrypted space. In my case I've move vangrat project dir from /home/me/vagrant/project > /var/www/vagrant/porject. And boom, is working!

Also you can try play around and turn off encryption in your home folder but this is up to you.

Hope this is useful.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.