Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a four node vmware ESX cluster built from HP BL495C blade server. Each blade contains two AMD Opteron 2435 CPU's (six core, 2600Mhz)

Just watched Brent Ozar's web cast on "sleepy cpu's" and after the recent stackoverflow problems I thought I'd check out my server.

CPU-Z reports a core speed of 528Mhz!

Does this look like it could be the same problem or is ESX doing tricks on me?

alt text

Specs:

Windows 2008, 4 vCPU, 4GB RAM. Storage is a SAN RAID10. Screenshot shows the server running a couple of 7zip processes to get the CPU high.

Update:

Looks like our cluster has been configured based on recommendation of this document page 5. Also the ESX vsphere configuration is saying that "Power Management Technology" s "Not available". Does that mean it defaults to "snooze mode"?

Update:

Different software... different result. alt text

alt text

share|improve this question
    
What OS? How many vCPUs does the VM have? –  andyhky Nov 11 '10 at 14:51
    
Windows 2008 and this guest has 4 CPU's (as per the taskmanager photo) and I'm running a lot of 7zip's to get the CPU up high to try to see if the buz speed pops up... –  Guy Nov 11 '10 at 15:14
1  
could it be something to do with the "cool 'n quiet" - try turning that off in the bios on your hypervisor, and then make sure the feature is disabled in the configuration tab (under power section, there is one that may be set to 'dynamic' - change that to static) –  Marm0t Nov 11 '10 at 15:16
    
@Marm0t - It seems they are set to "dynamic" or "OS Control" mode. But the ESX server is reports the "Power Management Technology" as "Not available". Does the serve default to slow mode? –  Guy Nov 11 '10 at 16:40
    
I had a similar issue with power states on my ESX box, but it had to do with my board cutting power off to the PCI-E cards when the system was idle..there goes the NIC! I disabled cool n' quiet as well as C1E states and it fixed the throttling hoopla. There is also an advanced setting to disable C1E on boot in vSphere but I can't remember the exact name atm. Also aside from CPU-Z, what is vSphere reporting for that machine MHz wise? Do they match up? I would trust vSphere over what CPU-Z is reporting on the guest. –  Diffuser Nov 11 '10 at 21:30
show 2 more comments

2 Answers

up vote 1 down vote accepted

Guy - There are two kinds of power management, one is c states (i.e. c1enhance for intel - something similar for amd), and the other is p states (cool 'n quiet for amd). Is this 'CPU power management' listed under advanced software features in your conifiguration -or are you seeing this somewhere else? If CPU power management is disabled that might mean you already have cool 'n quiet disabled in your bios.

Power.CpuPolicy should be set to static if you want cpuz to read the clock frequency. However - dynamic 'dynamically' scales frequency up and down. It may make sense cpuz reads only 528Mhz - your server will run at the lowest frequency necessary to accomplish the current task.

See Faq 1 at CPUZ . Maybe try running a load on your server and then see if the frequency scales up. If it is not scaling you will need to do 2 things to (possibly) fix them:

  1. set Power.CpuPolicy to static
  2. Reboot and set Cool 'n quiet to disabled.

Do the same for C1Enhanced in the bios if the above doesn't work. If you do this you will be running hotter / more power (if you server is constantly idle). These settings don't really matter if your server CPU is utilized fully (near 75%+ constant CPU load- i.e. you can't save any power if you're always running close to 100%!).

Finally - CPUZ is not a great choice for determining processor specs in a vm. You should use some benchmarking software (SPEC) to get an accurate understanding of what your processor is doing! I have windows machines under ESXi that read all kinds of weird ( some read 50% max cpu utilization when it is 100%- some get confused if you add/remove processors/ switch to a computer with higher/lower base clock speeds), so I wouldn't rely on any software based CPU gauges. You really need to run a benchmark to give you an understanding of whats actually going on, as there is too much between you and the CPU when virtualizing!

share|improve this answer
    
Will have a play on a test blade and vm... Brent did say he'd seen the same thing on vm's as well as physical boxes, but you never trust anything anyone says, do you ;) –  Guy Nov 11 '10 at 22:50
add comment

Could be, you're lucky having a DRS cluster as you can easily switch off power saving for your servers with no user impact to see if it was this problem or not.

share|improve this answer
    
It's not quite that simple, but we should be able to check the config in a sister server/blade to see what that is doing. Hopefully tomorrow. –  Guy Nov 11 '10 at 16:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.