Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had installed MySQL server 5.1.1 on my PC (windows 7 ultimate 32bit, CPU Dual core 2.60 MHz, 2.00 GB RAM) and it was up and running well, until last Wednesday I was forced to uninstall it, and now when I reinstall it,in the last level of creating server instance, when I press execute, It checks OK for 'prepare configuration' and 'write configuration file', but in 'start server' it faces an error and doesn't continue... and afterward when I try to start MySQL service manually from windows services, It says: "Windows could not start MySQL service on local computer. Error 1067: The process terminated unexpectedly." When I wanna check error log to see why? the data folder of mysql is empty! I tried everything: port 3306 is open and no one is listening on it. my firewall has mysql exception and I even disabled it. i even tried new versions of mysql 5.1.2 it's the same. What should I do... please guys! this is urgent.

share|improve this question

migrated from stackoverflow.com Nov 11 '10 at 16:40

This question came from our site for professional and enthusiast programmers.

2 Answers 2

If your 'data' Directory is empty you already found the problem. It ain't supposed to empty, at least the 'mysql' Directory within and files are necessary so it can start.

share|improve this answer
    
Heh, well spotted! :) +1 –  Pekka 웃 Nov 10 '10 at 11:45
    
thanks, but how can i fix it... the error is from installation and I don't know how to fix this? –  Ehphan Nov 10 '10 at 11:56

Look into the server's error log (your_hostname.err). You should find a detailed message there.

IIRC, 1067 is a missing data directory.

share|improve this answer
    
I fixed this empty folder somehow and now in .err files there is some errors:101110 15:23:12 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it. I ran mysql_upgrade but it's still the same and wth starting mysql server the error does not change –  Ehphan Nov 10 '10 at 11:59
    
@Ehphan well, then fix the errors? –  Pekka 웃 Nov 10 '10 at 11:59
    
and there's also another error in the last line of error log and says: 101110 15:29:08 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist –  Ehphan Nov 10 '10 at 12:04
    
@Ehphan You need certain tables in the data directory. They should have been installed automatically. You should find them and copy them over –  Pekka 웃 Nov 10 '10 at 12:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.