Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a ubuntu 10.04 with apache 2 and samba. We set apache2 /var/www/ to be on a Windows Directory over the network using samba. It's all working but I can't seem to find a way to give writing permission on this directory. I've tried both on linux and windows. Any tips?

share|improve this question

2 Answers 2

What version of Windows are you using and have you looked at NTLM as the cause?

http://technet.microsoft.com/en-us/library/cc960646.aspx

I've had issues on Windows Vista and 7 when trying to authenticate with Samba, I had to change the windows registry key “HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel” to “1”.

What do your logs tell you?

share|improve this answer
    
It's a Windows Server 2008. I don't really know what a NTLM is. But I can see the directory, it's readable but i need to change the permission to writeable. –  Eduardo Mello Nov 11 '10 at 20:58
    
In the samba configuration file for that path you need to add writable = yes –  Michael Burns Nov 11 '10 at 21:11

Have you been running SWAT already? It's a graphical front-end for Samba, using a web interface so it shows up on http:localhost/901 on the Ubuntu-machine.

Manually editing samba-configuration files and setting permissions may be daunting, but with SWAT it's really easy.

https://help.ubuntu.com/community/Swat

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.